summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/pscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/pscan')
-rw-r--r--dev-util/pscan/Manifest1
-rw-r--r--dev-util/pscan/metadata.xml7
-rw-r--r--dev-util/pscan/pscan-20000721-r1.ebuild33
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/pscan/Manifest b/dev-util/pscan/Manifest
new file mode 100644
index 000000000000..ea6fa722ef90
--- /dev/null
+++ b/dev-util/pscan/Manifest
@@ -0,0 +1 @@
+DIST pscan.tar.gz 14555 SHA256 0f3a9f5b91ddba5363d77734a717f541260b2154c964b9ce63511b3ff50272ee SHA512 83196cc9c450217fc2287d38fd1a0b9d1d9951b8f6328b6b9f7f50b680f653b099af04d4c448f3cb2b2a96871eec8772557851e887faa2f41dc259f01c031e78 WHIRLPOOL b5fe4022dd1234ab6b976ee3984114e50080ceec0f8b5cff539824c6b9f00ee83c5b7ebfb75e685d14efe655a0c4ac464fc80cfb485a10e7225c19c5bbdef52a
diff --git a/dev-util/pscan/metadata.xml b/dev-util/pscan/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/dev-util/pscan/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/pscan/pscan-20000721-r1.ebuild b/dev-util/pscan/pscan-20000721-r1.ebuild
new file mode 100644
index 000000000000..e275b7f89fcd
--- /dev/null
+++ b/dev-util/pscan/pscan-20000721-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A limited problem scanner for C source files"
+HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
+# I wish upstream would version their files, even if it's only with a date
+SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# Does NOT contain a testsuite, but does contain a test.c that confuses src_test
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
+}
+
+src_install() {
+ newbin pscan printf-scan || die
+ dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+}