summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-05-13 13:10:15 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-05-13 13:10:58 +0300
commit2c1a12b8c8bec9b0bc4b00e468a0b6da3f55662c (patch)
treec09b2421383efaa497b00dcb49bba150054edf9a /dev-util/pycharm-community
parentdev-python/mpmath: x86 stable wrt bug #722534 (diff)
downloadgentoo-2c1a12b8c8bec9b0bc4b00e468a0b6da3f55662c.tar.gz
gentoo-2c1a12b8c8bec9b0bc4b00e468a0b6da3f55662c.tar.bz2
gentoo-2c1a12b8c8bec9b0bc4b00e468a0b6da3f55662c.zip
dev-util/pycharm-community: allow bundled jdk on demand
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/metadata.xml3
-rw-r--r--dev-util/pycharm-community/pycharm-community-2020.1.ebuild15
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/pycharm-community/metadata.xml b/dev-util/pycharm-community/metadata.xml
index d21de2d9f07b..c405595aa1a2 100644
--- a/dev-util/pycharm-community/metadata.xml
+++ b/dev-util/pycharm-community/metadata.xml
@@ -5,4 +5,7 @@
<name>Mikle Kolyada</name>
<email>zlogene@gentoo.org</email>
</maintainer>
+<use>
+ <flag name="bundled-jdk">Use bundled jdk</flag>
+</use>
</pkgmetadata>
diff --git a/dev-util/pycharm-community/pycharm-community-2020.1.ebuild b/dev-util/pycharm-community/pycharm-community-2020.1.ebuild
index 0600c9803a8d..f8be402a51b3 100644
--- a/dev-util/pycharm-community/pycharm-community-2020.1.ebuild
+++ b/dev-util/pycharm-community/pycharm-community-2020.1.ebuild
@@ -12,8 +12,9 @@ SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="+bundled-jdk"
-RDEPEND=">=virtual/jre-1.8
+RDEPEND="!bundled-jdk? ( >=virtual/jre-1.8 )
dev-libs/libdbusmenu
dev-python/pip"
@@ -25,16 +26,16 @@ QA_PREBUILT="opt/${PN}/bin/fsnotifier
MY_PN=${PN/-community/}
-src_prepare() {
- default
-
- rm -rf jre || die
-}
-
src_install() {
insinto /opt/${PN}
doins -r *
+ if use bundled-jdk; then
+ fperms -R a+x /opt/pycharm-community/jbr/bin/
+ else
+ rm -r "${D}"/opt/pycharm-community/jbr/ || die
+ fi
+
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}