summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2017-06-09 20:04:27 +0700
committerAndrey Grozin <grozin@gentoo.org>2017-06-09 20:05:51 +0700
commitfba20f11094a23d731b110be78c87a72257ea01c (patch)
tree8d8678ccfb6121cf842702c093536f4abb7daa99 /dev-util/pycharm-community
parentdev-lang/php: Version bump for 7.0.20 (diff)
downloadgentoo-fba20f11094a23d731b110be78c87a72257ea01c.tar.gz
gentoo-fba20f11094a23d731b110be78c87a72257ea01c.tar.bz2
gentoo-fba20f11094a23d731b110be78c87a72257ea01c.zip
dev-util/pycharm-community: bump to 2017.1.3
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.1.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 8ebb09fd539a..5db3992ad25d 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -1,2 +1,3 @@
DIST pycharm-community-2016.3.2.tar.gz 215633678 SHA256 e1092d3692118f9097e4182edfccc76159160353b7d7379cada3249b9e2d4f39 SHA512 64f8fd908c2165e4534f77596e6f9a86e72a04390432a0c1206d8a5cfde8a54067d5747a6f1f2a5ba5bb168e311d5f432939c87a15f871330ce2c2e42c9bfc8a WHIRLPOOL 92320d3f96b76148bba1e0ead93578cde6890119fa963e1390b7da2ea570d4b99e6bebdffe6167e283d534073b06cd063c2d9e70c0100436afc6b6d0fd264eda
+DIST pycharm-community-2017.1.3.tar.gz 195297254 SHA256 6dedbf06c62490047b5d8a539c94af89affc80048f4cf79eea25d29f50894a1b SHA512 9e8f1ab779bd10073e7cd1922cc0b8d43bebd02b64b1626d242d2fd1fdf21fe66811cc1809c17675b9ad91aff26bbef5c6b2c8afd47f70486dc66c7e66cde017 WHIRLPOOL 51212ddcf95167387fab8c274d098b77f74ce4832720fdffc62694e34d3eba4a77df12ea5c99a654ca97f6102fd02003afc44a8107fcd200ee9e2e17a6d8bf33
DIST pycharm-community-2017.1.tar.gz 195354973 SHA256 6669120b68873a0bcb7faf179ea79f7c2dd7eac34d377d1f574724604b70e692 SHA512 056b23ba8b6cda4d609a2011b18e207f470670048185afeff0ad18dff8093d0ff0efa20a0a20b020ce81bc23008a31c7c9620c7fb4dc1f7e3d3b62316005322c WHIRLPOOL 0fefc16a433d41d64034a2df057a27bd035ec92cc7e00246f93a1afc0ef2350e919018071781e87d6285526993997507616f01f310e8c308bc4a1552b3eb4ef3
diff --git a/dev-util/pycharm-community/pycharm-community-2017.1.3.ebuild b/dev-util/pycharm-community/pycharm-community-2017.1.3.ebuild
new file mode 100644
index 000000000000..5b7ba98c48d1
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2017.1.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}