summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2021-12-27 20:51:57 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-01-05 20:18:06 +0100
commite78e6351429ea293f27c43ec6d03fc68b1ea0b24 (patch)
tree43faf4263dece0c3925f70a095805c93750af32d /dev-util/rt-tests
parentdev-util/rt-tests: Bump to v2.3 (diff)
downloadgentoo-e78e6351429ea293f27c43ec6d03fc68b1ea0b24.tar.gz
gentoo-e78e6351429ea293f27c43ec6d03fc68b1ea0b24.tar.bz2
gentoo-e78e6351429ea293f27c43ec6d03fc68b1ea0b24.zip
dev-util/rt-tests: Drop old
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/23551 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-util/rt-tests')
-rw-r--r--dev-util/rt-tests/Manifest1
-rw-r--r--dev-util/rt-tests/files/rt-tests-2.2-musl.patch352
-rw-r--r--dev-util/rt-tests/rt-tests-2.2.ebuild38
3 files changed, 0 insertions, 391 deletions
diff --git a/dev-util/rt-tests/Manifest b/dev-util/rt-tests/Manifest
index b157404b489c..6f230e4f00d8 100644
--- a/dev-util/rt-tests/Manifest
+++ b/dev-util/rt-tests/Manifest
@@ -1,2 +1 @@
-DIST rt-tests-2.2.tar.xz 115120 BLAKE2B 46db78d32b2d5830859757c21e42d4e21cb0da8b2ebcbf8ba738c8e3832a6ea597d686ee6c9cad23f269853ad188219f46a0e5326124f056b4822619076268ac SHA512 826dc8894dd8670e705566b5224f54bdee89e5b48f21ca00e6c4061f28c4fbe2dab14c1e1b1302fec7011dbf28f3eb88c1b8adc137fed7d17958ea972e3c08b1
DIST rt-tests-2.3.tar.xz 115000 BLAKE2B d5f6a31a31340873348b5ffa6c706deb080e9686944a759fa4e4d53f2041d3f27aa1e9512d7413438bce7c61e05e2495c96eeef0b976ee09377f89d847225aef SHA512 3bf6fe95c5ac9911fb51fba1d4a8e6ad3b96a6cdce464372917673862801353cbbb377c76d3a19325f0b5402f65daf5c605e496d7460949615069366a00a978a
diff --git a/dev-util/rt-tests/files/rt-tests-2.2-musl.patch b/dev-util/rt-tests/files/rt-tests-2.2-musl.patch
deleted file mode 100644
index caa8d415aad5..000000000000
--- a/dev-util/rt-tests/files/rt-tests-2.2-musl.patch
+++ /dev/null
@@ -1,352 +0,0 @@
-From 0b7a1e0d3463aa8aa4b7dcad0ec154e658d68036 Mon Sep 17 00:00:00 2001
-From: Kurt Kanzenbach <kurt@kmk-computers.de>
-Date: Wed, 1 Apr 2020 20:15:24 +0200
-Subject: [PATCH] all: Fix musl build
-
-There are a few problems:
-
- * pi stress: pthread_attr_setaffinity_np() is not supported
- * cyclictest: SIGEV_THREAD_ID is not supported
- * hackbench: Fix include
- * all: Fix sched_* calls
-
-With these changes applied, the rt-tests seem to run fine.
-
-Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
----
- Makefile | 5 --
- src/backfire/sendme.c | 1
- src/cyclictest/cyclictest.c | 70 ++++------------------------------
- src/hackbench/hackbench.c | 4 +
- src/include/musl.h | 28 +++++++++++++
- src/lib/rt-utils.c | 1
- src/pi_tests/classic_pi.c | 2
- src/pi_tests/tst-mutexpi10.c | 2
- src/pmqtest/pmqtest.c | 1
- src/ptsematest/ptsematest.c | 1
- src/rt-migrate-test/rt-migrate-test.c | 1
- src/sched_deadline/cyclicdeadline.c | 1
- 12 files changed, 50 insertions(+), 67 deletions(-)
- create mode 100644 src/include/musl.h
-
---- a/Makefile
-+++ b/Makefile
-@@ -7,7 +7,6 @@ OBJDIR = bld
- sources = cyclictest.c \
- hackbench.c \
- pip_stress.c \
-- pi_stress.c \
- pmqtest.c \
- ptsematest.c \
- rt-migrate-test.c \
-@@ -42,7 +41,6 @@ ifeq (${PYLIB},)
- endif
-
- MANPAGES = src/cyclictest/cyclictest.8 \
-- src/pi_tests/pi_stress.8 \
- src/ptsematest/ptsematest.8 \
- src/rt-migrate-test/rt-migrate-test.8 \
- src/sigwaittest/sigwaittest.8 \
-@@ -130,9 +128,6 @@ deadline_test: $(OBJDIR)/deadline_test.o
- signaltest: $(OBJDIR)/signaltest.o $(OBJDIR)/librttest.a $(OBJDIR)/librttestnuma.a
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LIBS) $(RTTESTLIB) $(RTTESTNUMA)
-
--pi_stress: $(OBJDIR)/pi_stress.o $(OBJDIR)/librttest.a
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LIBS) $(RTTESTLIB)
--
- hwlatdetect: src/hwlatdetect/hwlatdetect.py
- chmod +x src/hwlatdetect/hwlatdetect.py
- ln -s src/hwlatdetect/hwlatdetect.py hwlatdetect
---- a/src/backfire/sendme.c
-+++ b/src/backfire/sendme.c
-@@ -29,6 +29,7 @@
- #include <string.h>
- #include <time.h>
- #include <errno.h>
-+#include "musl.h"
- #include "rt-utils.h"
- #include "rt-get_cpu.h"
-
---- a/src/cyclictest/cyclictest.c
-+++ b/src/cyclictest/cyclictest.c
-@@ -33,6 +33,7 @@
- #include <sys/utsname.h>
- #include <sys/mman.h>
- #include <sys/syscall.h>
-+#include "musl.h"
- #include "rt_numa.h"
-
- #include "rt-utils.h"
-@@ -502,12 +503,8 @@ static void *timerthread(void *param)
- {
- struct thread_param *par = param;
- struct sched_param schedp;
-- struct sigevent sigev;
- sigset_t sigset;
-- timer_t timer;
- struct timespec now, next, interval, stop;
-- struct itimerval itimer;
-- struct itimerspec tspec;
- struct thread_stat *stat = par->stats;
- int stopped = 0;
- cpu_set_t mask;
-@@ -538,14 +535,6 @@ static void *timerthread(void *param)
- sigaddset(&sigset, par->signal);
- sigprocmask(SIG_BLOCK, &sigset, NULL);
-
-- if (par->mode == MODE_CYCLIC) {
-- sigev.sigev_notify = SIGEV_THREAD_ID | SIGEV_SIGNAL;
-- sigev.sigev_signo = par->signal;
-- sigev.sigev_notify_thread_id = stat->tid;
-- timer_create(par->clock, &sigev, &timer);
-- tspec.it_interval = interval;
-- }
--
- memset(&schedp, 0, sizeof(schedp));
- schedp.sched_priority = par->prio;
- if (setscheduler(0, par->policy, &schedp))
-@@ -600,20 +589,6 @@ static void *timerthread(void *param)
- stop = now;
- stop.tv_sec += duration;
- }
-- if (par->mode == MODE_CYCLIC) {
-- if (par->timermode == TIMER_ABSTIME)
-- tspec.it_value = next;
-- else
-- tspec.it_value = interval;
-- timer_settime(timer, par->timermode, &tspec, NULL);
-- }
--
-- if (par->mode == MODE_SYS_ITIMER) {
-- itimer.it_interval.tv_sec = interval.tv_sec;
-- itimer.it_interval.tv_usec = interval.tv_nsec / 1000;
-- itimer.it_value = itimer.it_interval;
-- setitimer(ITIMER_REAL, &itimer, NULL);
-- }
-
- stat->threadstarted++;
-
-@@ -621,16 +596,10 @@ static void *timerthread(void *param)
-
- uint64_t diff;
- unsigned long diff_smi = 0;
-- int sigs, ret;
-+ int ret;
-
- /* Wait for next period */
- switch (par->mode) {
-- case MODE_CYCLIC:
-- case MODE_SYS_ITIMER:
-- if (sigwait(&sigset, &sigs) < 0)
-- goto out;
-- break;
--
- case MODE_CLOCK_NANOSLEEP:
- if (par->timermode == TIMER_ABSTIME) {
- ret = clock_nanosleep(par->clock, TIMER_ABSTIME,
-@@ -751,11 +720,6 @@ static void *timerthread(void *param)
-
- next.tv_sec += interval.tv_sec;
- next.tv_nsec += interval.tv_nsec;
-- if (par->mode == MODE_CYCLIC) {
-- int overrun_count = timer_getoverrun(timer);
-- next.tv_sec += overrun_count * interval.tv_sec;
-- next.tv_nsec += overrun_count * interval.tv_nsec;
-- }
- tsnorm(&next);
-
- while (tsgreater(&now, &next)) {
-@@ -780,17 +744,6 @@ out:
- pthread_mutex_unlock(&refresh_on_max_lock);
- }
-
-- if (par->mode == MODE_CYCLIC)
-- timer_delete(timer);
--
-- if (par->mode == MODE_SYS_ITIMER) {
-- itimer.it_value.tv_sec = 0;
-- itimer.it_value.tv_usec = 0;
-- itimer.it_interval.tv_sec = 0;
-- itimer.it_interval.tv_usec = 0;
-- setitimer(ITIMER_REAL, &itimer, NULL);
-- }
--
- /* close msr file */
- if (smi)
- close(par->msr_fd);
-@@ -1174,7 +1127,8 @@ static void process_options(int argc, ch
- case OPT_VERBOSE: verbose = 1; break;
- case 'x':
- case OPT_POSIX_TIMERS:
-- use_nanosleep = MODE_CYCLIC; break;
-+ fatal("--posix_timers is not available on your libc\n");
-+ break;
- case '?':
- case OPT_HELP:
- display_help(0); break;
-@@ -1207,13 +1161,6 @@ static void process_options(int argc, ch
- }
- }
-
-- if ((use_system == MODE_SYS_OFFSET) && (use_nanosleep == MODE_CYCLIC)) {
-- warn("The system option requires clock_nanosleep\n");
-- warn("and is not compatible with posix_timers\n");
-- warn("Using clock_nanosleep\n");
-- use_nanosleep = MODE_CLOCK_NANOSLEEP;
-- }
--
- /* if smp wasn't requested, test for numa automatically */
- if (!smp) {
- numa = numa_initialize();
-@@ -1943,7 +1890,6 @@ int main(int argc, char **argv)
-
- }
-
--
- mode = use_nanosleep + use_system;
-
- sigemptyset(&sigset);
-@@ -1993,16 +1939,18 @@ int main(int argc, char **argv)
- void *stack;
- void *currstk;
- size_t stksize;
-+ int err;
-
- /* find the memory node associated with the cpu i */
- node = rt_numa_numa_node_of_cpu(cpu);
-
-- /* get the stack size set for this thread */
-- if (pthread_attr_getstack(&attr, &currstk, &stksize))
-+ /* get the stack size set for for this thread */
-+ err = pthread_attr_getstack(&attr, &currstk, &stksize);
-+ if (err != EINVAL)
- fatal("failed to get stack size for thread %d\n", i);
-
- /* if the stack size is zero, set a default */
-- if (stksize == 0)
-+ if (err == EINVAL || stksize == 0)
- stksize = PTHREAD_STACK_MIN * 2;
-
- /* allocate memory for a stack on appropriate node */
---- a/src/hackbench/hackbench.c
-+++ b/src/hackbench/hackbench.c
-@@ -24,13 +24,15 @@
- #include <sys/socket.h>
- #include <sys/wait.h>
- #include <sys/time.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <limits.h>
- #include <getopt.h>
- #include <signal.h>
- #include <setjmp.h>
- #include <sched.h>
-
-+#include "musl.h"
-+
- static unsigned int datasize = 100;
- static unsigned int loops = 100;
- static unsigned int num_groups = 10;
---- /dev/null
-+++ b/src/include/musl.h
-@@ -0,0 +1,28 @@
-+/*
-+ * Copyright (C) 2020 Kurt Kanzenbach <kurt@kmk-computers.de>
-+ * Time-stamp: <2020-04-04 10:54:01 kurt>
-+ */
-+
-+#ifndef _MUSL_H_
-+#define _MUSL_H_
-+
-+#include <unistd.h>
-+#include <sys/syscall.h>
-+
-+/*
-+ * Musl someshow defines sched_* to ENOSYS which is not correct ...
-+ * See commit 1e21e78bf7a5 ("add support for thread scheduling (POSIX TPS option)")
-+ *
-+ * Workaround: define them to syscall(...)
-+ */
-+
-+#define sched_getparam(pid, param) \
-+ syscall(SYS_sched_getparam, pid, param)
-+#define sched_setparam(pid, param) \
-+ syscall(SYS_sched_setparam, pid, param)
-+#define sched_getscheduler(pid) \
-+ syscall(SYS_sched_getscheduler, pid)
-+#define sched_setscheduler(pid, policy, param) \
-+ syscall(SYS_sched_setscheduler, pid, policy, param)
-+
-+#endif /* _MUSL_H_ */
---- a/src/lib/rt-utils.c
-+++ b/src/lib/rt-utils.c
-@@ -24,6 +24,7 @@
- #include <time.h>
- #include <sys/time.h>
-
-+#include "musl.h"
- #include "rt-utils.h"
- #include "rt-sched.h"
- #include "rt-error.h"
---- a/src/pi_tests/classic_pi.c
-+++ b/src/pi_tests/classic_pi.c
-@@ -34,6 +34,8 @@
- #include <signal.h>
- #include <getopt.h>
-
-+#include "musl.h"
-+
- /* test timeout */
- #define TIMEOUT 2
-
---- a/src/pi_tests/tst-mutexpi10.c
-+++ b/src/pi_tests/tst-mutexpi10.c
-@@ -35,6 +35,8 @@
- #include <string.h>
- #include <signal.h>
-
-+#include "musl.h"
-+
- /* test timeout */
- #define TIMEOUT 2
-
---- a/src/pmqtest/pmqtest.c
-+++ b/src/pmqtest/pmqtest.c
-@@ -24,6 +24,7 @@
- #include <pthread.h>
- #include <inttypes.h>
-
-+#include "musl.h"
- #include "rt-utils.h"
- #include "rt-get_cpu.h"
- #include "rt-error.h"
---- a/src/ptsematest/ptsematest.c
-+++ b/src/ptsematest/ptsematest.c
-@@ -22,6 +22,7 @@
- #include <pthread.h>
- #include <inttypes.h>
-
-+#include "musl.h"
- #include "rt-utils.h"
- #include "rt-get_cpu.h"
- #include "rt-error.h"
---- a/src/rt-migrate-test/rt-migrate-test.c
-+++ b/src/rt-migrate-test/rt-migrate-test.c
-@@ -27,6 +27,7 @@
-
- #include <linux/unistd.h>
-
-+#include "musl.h"
- #include "rt-utils.h"
-
- int nr_tasks;
---- a/src/sched_deadline/cyclicdeadline.c
-+++ b/src/sched_deadline/cyclicdeadline.c
-@@ -30,6 +30,7 @@
- #include <linux/unistd.h>
- #include <linux/magic.h>
-
-+#include "musl.h"
- #include "rt-utils.h"
- #include "rt-sched.h"
- #include "rt-error.h"
diff --git a/dev-util/rt-tests/rt-tests-2.2.ebuild b/dev-util/rt-tests/rt-tests-2.2.ebuild
deleted file mode 100644
index 247753110450..000000000000
--- a/dev-util/rt-tests/rt-tests-2.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit python-single-r1 toolchain-funcs
-
-DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
-HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
-SRC_URI="
- https://kernel.org/pub/linux/utils/rt-tests/${P}.tar.xz
- https://kernel.org/pub/linux/utils/rt-tests/older/${P}.tar.xz"
-
-LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- sys-process/numactl"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- default
- use elibc_musl && eapply "${FILESDIR}/${P}-musl.patch"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" AR="$(tc-getAR)"
-}
-
-src_install() {
- emake CC="$(tc-getCC)" prefix=/usr DESTDIR="${ED}" install
- python_fix_shebang "${ED}"
- python_optimize
-}