summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-24 03:49:05 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-24 04:07:25 -0500
commit2201dbb7de7aaf045761d78735a445cecca16f44 (patch)
tree037e0419d2e9f0e5380774d4690e4f4aa7d02109 /dev-util/strace
parentdev-util/strace: mark 4.13 arm64/ia64/m68k/ppc/s390/sh/sparc stable #596200 (diff)
downloadgentoo-2201dbb7de7aaf045761d78735a445cecca16f44.tar.gz
gentoo-2201dbb7de7aaf045761d78735a445cecca16f44.tar.bz2
gentoo-2201dbb7de7aaf045761d78735a445cecca16f44.zip
dev-util/strace: set up default build settings #602192
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/strace-4.13.ebuild10
-rw-r--r--dev-util/strace/strace-4.14.ebuild10
-rw-r--r--dev-util/strace/strace-4.15.ebuild10
-rw-r--r--dev-util/strace/strace-9999.ebuild10
4 files changed, 36 insertions, 4 deletions
diff --git a/dev-util/strace/strace-4.13.ebuild b/dev-util/strace/strace-4.13.ebuild
index b0c7288791bb..9804db50c7f4 100644
--- a/dev-util/strace/strace-4.13.ebuild
+++ b/dev-util/strace/strace-4.13.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
@@ -48,6 +48,14 @@ src_prepare() {
}
src_configure() {
+ # Set up the default build settings, and then use the naems strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
econf $(use_with unwind libunwind)
}
diff --git a/dev-util/strace/strace-4.14.ebuild b/dev-util/strace/strace-4.14.ebuild
index 6c5ede46696d..df019fe92aa1 100644
--- a/dev-util/strace/strace-4.14.ebuild
+++ b/dev-util/strace/strace-4.14.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
@@ -48,6 +48,14 @@ src_prepare() {
}
src_configure() {
+ # Set up the default build settings, and then use the naems strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
econf $(use_with unwind libunwind)
}
diff --git a/dev-util/strace/strace-4.15.ebuild b/dev-util/strace/strace-4.15.ebuild
index 6c5ede46696d..df019fe92aa1 100644
--- a/dev-util/strace/strace-4.15.ebuild
+++ b/dev-util/strace/strace-4.15.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
@@ -48,6 +48,14 @@ src_prepare() {
}
src_configure() {
+ # Set up the default build settings, and then use the naems strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
econf $(use_with unwind libunwind)
}
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 6c5ede46696d..df019fe92aa1 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
@@ -48,6 +48,14 @@ src_prepare() {
}
src_configure() {
+ # Set up the default build settings, and then use the naems strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
econf $(use_with unwind libunwind)
}