summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-07-05 23:36:52 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-07-05 23:46:43 +0200
commit9cce4d19880ad614c0e438c054baf74b9a6f4400 (patch)
tree670ee798d5d2dde2081292b7ddff1715b46b96bd /dev-util/strace
parentdev-util/strace: Bump to version 4.18 (diff)
downloadgentoo-9cce4d19880ad614c0e438c054baf74b9a6f4400.tar.gz
gentoo-9cce4d19880ad614c0e438c054baf74b9a6f4400.tar.bz2
gentoo-9cce4d19880ad614c0e438c054baf74b9a6f4400.zip
dev-util/strace: Sync live ebuild
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/strace-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 9ec77eb9b806..5d4fba688f4b 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=5
inherit flag-o-matic eutils toolchain-funcs
@@ -23,11 +23,15 @@ IUSE="aio perl static unwind"
LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
# strace only uses the header from libaio to decode structs
-DEPEND="static? ( ${LIB_DEPEND} )
+DEPEND="
+ static? ( ${LIB_DEPEND} )
aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- perl? ( dev-lang/perl )"
+ sys-kernel/linux-headers
+"
+RDEPEND="
+ !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )
+"
src_prepare() {
if epatch_user || [[ ! -e configure ]] ; then