summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-07-21 11:19:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-07-21 11:19:58 -0400
commit1ea5ea8366262f347d003d9c337f7a92a81477ac (patch)
tree6dc36e33877f48432386cf3d9c0af8b678ec6fc0 /dev-util/valgrind/valgrind-3.19.0.ebuild
parentprofiles: mask dev-perl/Search-Xapian for removal (diff)
downloadgentoo-1ea5ea8366262f347d003d9c337f7a92a81477ac.tar.gz
gentoo-1ea5ea8366262f347d003d9c337f7a92a81477ac.tar.bz2
gentoo-1ea5ea8366262f347d003d9c337f7a92a81477ac.zip
dev-util/valgrind: add musl support
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-util/valgrind/valgrind-3.19.0.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-3.19.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-util/valgrind/valgrind-3.19.0.ebuild b/dev-util/valgrind/valgrind-3.19.0.ebuild
index 5a2a07829d30..4ff9c8e71913 100644
--- a/dev-util/valgrind/valgrind-3.19.0.ebuild
+++ b/dev-util/valgrind/valgrind-3.19.0.ebuild
@@ -34,6 +34,12 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-3.15.0-Build-ldst_multiple-test-with-fno-pie.patch
+ # conditionally copy musl specific suppressions && apply patch
+ if use elibc_musl ; then
+ cp "${FILESDIR}/musl.supp" "${S}"
+ eapply "${FILESDIR}/valgrind-3.13.0-malloc.patch"
+ fi
+
if [[ ${CHOST} == *-solaris* ]] ; then
# upstream doesn't support this, but we don't build with
# Sun/Oracle ld, we have a GNU toolchain, so get some things