summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-12-12 15:26:37 -0600
committerAustin English <wizardedit@gentoo.org>2017-12-12 15:59:33 -0600
commit625541b28d782f5f55a13427424a7eb2b9e7ebf3 (patch)
tree012251215e6c254c6c72010592299344879dd3c6 /dev-util/valgrind/valgrind-9999.ebuild
parentdev-db/slony1: Restrict Test (diff)
downloadgentoo-625541b28d782f5f55a13427424a7eb2b9e7ebf3.tar.gz
gentoo-625541b28d782f5f55a13427424a7eb2b9e7ebf3.tar.bz2
gentoo-625541b28d782f5f55a13427424a7eb2b9e7ebf3.zip
dev-util/valgrind: also strip -fstack-protector-strong/-fstack-protector-all
Gentoo-Bug: https://bugs.gentoo.org/620402 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/valgrind/valgrind-9999.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 6414792ca62c..855bd8a16c29 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -31,9 +31,6 @@ src_prepare() {
# Respect CFLAGS, LDFLAGS
eapply "${FILESDIR}"/${PN}-3.7.0-respect-flags.patch
- # Changing Makefile.all.am to disable SSP
- eapply "${FILESDIR}"/${PN}-3.7.0-fno-stack-protector.patch
-
# Allow users to test their own patches
eapply_user
@@ -51,10 +48,15 @@ src_configure() {
# while compiling insn_sse.c in none/tests/x86
# -fstack-protector more undefined references to __guard and __stack_smash_handler
# because valgrind doesn't link to glibc (bug #114347)
+ # -fstack-protector-all Fails same way as -fstack-protector/-fstack-protector-strong.
+ # Note: -fstack-protector-explicit is a no-op for Valgrind, no need to strip it
+ # -fstack-protector-strong See -fstack-protector (bug #620402)
# -m64 -mx32 for multilib-portage, bug #398825
# -ggdb3 segmentation fault on startup
filter-flags -fomit-frame-pointer
filter-flags -fstack-protector
+ filter-flags -fstack-protector-all
+ filter-flags -fstack-protector-strong
filter-flags -m64 -mx32
replace-flags -ggdb3 -ggdb2