summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-12-20 12:10:04 +0500
committerAustin English <wizardedit@gentoo.org>2018-02-28 11:54:10 -0600
commit727a3c7b1f8094d1a66314e64077fe93dbe5dd2d (patch)
tree320c2c84ad1095b935e97615846047ea287d4d1c /dev-util/valgrind/valgrind-9999.ebuild
parentdev-ruby/ruby-pango: experimental bump to fix bug #616682 (diff)
downloadgentoo-727a3c7b1f8094d1a66314e64077fe93dbe5dd2d.tar.gz
gentoo-727a3c7b1f8094d1a66314e64077fe93dbe5dd2d.tar.bz2
gentoo-727a3c7b1f8094d1a66314e64077fe93dbe5dd2d.zip
dev-util/valgrind: fix for --xml-socket option
Fix for Qt Creator working. Closes: https://bugs.gentoo.org/641790 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/valgrind/valgrind-9999.ebuild')
-rw-r--r--dev-util/valgrind/valgrind-9999.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/dev-util/valgrind/valgrind-9999.ebuild b/dev-util/valgrind/valgrind-9999.ebuild
index 855bd8a16c29..2b96d5f5150c 100644
--- a/dev-util/valgrind/valgrind-9999.ebuild
+++ b/dev-util/valgrind/valgrind-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=6
inherit autotools flag-o-matic toolchain-funcs multilib pax-utils
DESCRIPTION="An open-source memory debugger for GNU/Linux"
@@ -39,7 +39,7 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=()
# Respect ar, bug #468114
tc-export AR
@@ -61,23 +61,23 @@ src_configure() {
replace-flags -ggdb3 -ggdb2
if use amd64 || use ppc64; then
- ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ ! has_multilib_profile && myconf+=("--enable-only64bit")
fi
# Force bitness on darwin, bug #306467
- use x86-macos && myconf="${myconf} --enable-only32bit"
- use x64-macos && myconf="${myconf} --enable-only64bit"
+ use x86-macos && myconf+=("--enable-only32bit")
+ use x64-macos && myconf+=("--enable-only64bit")
# Don't use mpicc unless the user asked for it (bug #258832)
if ! use mpi; then
- myconf="${myconf} --without-mpicc"
+ myconf+=("--without-mpicc")
fi
- econf ${myconf}
+ econf "${myconf[@]}"
}
src_install() {
- emake DESTDIR="${D}" install
+ default
if [[ ${PV} == "9999" ]]; then
# Otherwise FAQ.txt won't exist:
@@ -85,7 +85,7 @@ src_install() {
mv docs/FAQ.txt . || die "Couldn't move FAQ.txt"
fi
- dodoc AUTHORS FAQ.txt NEWS README*
+ dodoc FAQ.txt
pax-mark m "${ED}"/usr/$(get_libdir)/valgrind/*-*-linux