summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-16 04:58:51 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-16 04:59:13 -0400
commit3a0c640086917cd6ce03f9ce6e16003ad612dd4b (patch)
treeb5aa6a1e279e43f96b529484bf656b4d3d35f164 /dev-util/valgrind
parentdev-util/valgrind: remove older patches (diff)
downloadgentoo-3a0c640086917cd6ce03f9ce6e16003ad612dd4b.tar.gz
gentoo-3a0c640086917cd6ce03f9ce6e16003ad612dd4b.tar.bz2
gentoo-3a0c640086917cd6ce03f9ce6e16003ad612dd4b.zip
dev-util/valgrind: add support for glibc 2.22, bug #580092
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/files/valgrind-3.10.1-glibc-2.22.patch17
-rw-r--r--dev-util/valgrind/valgrind-3.10.1.ebuild7
2 files changed, 22 insertions, 2 deletions
diff --git a/dev-util/valgrind/files/valgrind-3.10.1-glibc-2.22.patch b/dev-util/valgrind/files/valgrind-3.10.1-glibc-2.22.patch
new file mode 100644
index 000000000000..aa44aec4a571
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.10.1-glibc-2.22.patch
@@ -0,0 +1,17 @@
+diff -Naur valgrind-3.10.1.orig/configure.ac valgrind-3.10.1/configure.ac
+--- valgrind-3.10.1.orig/configure.ac 2016-04-16 04:24:22.285314910 -0400
++++ valgrind-3.10.1/configure.ac 2016-04-16 04:39:03.437329726 -0400
+@@ -1032,6 +1032,13 @@
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
++ 2.22)
++ AC_MSG_RESULT(2.22 family)
++ AC_DEFINE([GLIBC_2_22], 1, [Define to 1 if you're using glibc 2.22.x])
++ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
++ ;;
+ darwin)
+ AC_MSG_RESULT(Darwin)
+ AC_DEFINE([DARWIN_LIBC], 1, [Define to 1 if you're using Darwin])
diff --git a/dev-util/valgrind/valgrind-3.10.1.ebuild b/dev-util/valgrind/valgrind-3.10.1.ebuild
index 7dd15a4e7a6f..b36dfc6a5fed 100644
--- a/dev-util/valgrind/valgrind-3.10.1.ebuild
+++ b/dev-util/valgrind/valgrind-3.10.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="5"
inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
DESCRIPTION="An open-source memory debugger for GNU/Linux"
@@ -46,6 +46,9 @@ src_prepare() {
# glibc 2.21 fix. Bug #554808.
epatch "${FILESDIR}"/${PN}-3.10.1-glibc-2.21.patch
+ # glibc 2.22 fix. Bug #580092
+ epatch "${FILESDIR}"/${PN}-3.10.1-glibc-2.22.patch
+
# Allow users to test their own patches
epatch_user