summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-04 01:19:41 -0500
committerSam James <sam@gentoo.org>2024-02-04 20:10:36 +0000
commit7480febe6f5367d2ae9daad03d64ae98f210c8fe (patch)
treecc326fc825a651ca55ab436f30c39de8b39da2ee /dev-util/yamllint/yamllint-1.33.0-r1.ebuild
parentapp-backup/borgmatic: drop setuptools runtime dep (diff)
downloadgentoo-7480febe6f5367d2ae9daad03d64ae98f210c8fe.tar.gz
gentoo-7480febe6f5367d2ae9daad03d64ae98f210c8fe.tar.bz2
gentoo-7480febe6f5367d2ae9daad03d64ae98f210c8fe.zip
dev-util/yamllint: remove never-correct dependency on setuptools
This was erroneously introduced upstream in https://github.com/adrienverge/yamllint/pull/321 with the logic that the generated entrypoint script used pkg_resources to load the entrypoint. This was always heavily conditional on how you installed it, and has better distribution-wide approaches to handle it, and is anyways no longer the case since a while now (because the code that generated pkg_resources entrypoints has stopped doing so). Upstream also accidentally got rid of this dependency while migrating to pyproject.toml, indicating exactly how important it is. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/yamllint/yamllint-1.33.0-r1.ebuild')
-rw-r--r--dev-util/yamllint/yamllint-1.33.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/yamllint/yamllint-1.33.0-r1.ebuild b/dev-util/yamllint/yamllint-1.33.0-r1.ebuild
new file mode 100644
index 000000000000..04ad8f3bce38
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.33.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest