summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-21 06:00:34 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-21 06:01:01 -0500
commit02a3f64089b68b7931ddbbdcb202adc1d7c4189b (patch)
tree934fe284511c7ba4346960129508dd30ed408431 /dev-util
parentmedia-gfx/graphicsmagick: Synced live ebuild. (diff)
downloadgentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.tar.gz
gentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.tar.bz2
gentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.zip
dev-util/premake: Bump to 4.4_beta5, 5.0.0_alpha12
Closes: https://bugs.gentoo.org/556906 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/premake/Manifest2
-rw-r--r--dev-util/premake/premake-4.4_beta5.ebuild36
-rw-r--r--dev-util/premake/premake-5.0.0_alpha12.ebuild33
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-util/premake/Manifest b/dev-util/premake/Manifest
index 7a51c0006feb..8a1a0a49bc73 100644
--- a/dev-util/premake/Manifest
+++ b/dev-util/premake/Manifest
@@ -1,2 +1,4 @@
DIST premake-4.3-src.zip 514366 BLAKE2B 5079f9d7c5dbe46d60149ec7c01523eaca5ab3cccce9f2f66d05905152ceb0b8bddaf181624288b722dd1534da6aef256ed5bb997db448f1499c8ab989277bc6 SHA512 df3a4f1e04afb6ae9acf06c063b084a4bcc7c48a98eebeb242eafef40de4097c6a6fe549369d9538b93efea35244222b9d26c15824f126a67b8f80abaecdf001
+DIST premake-4.4-beta5-src.zip 596883 BLAKE2B f4bf2b75946b6a442aced79f1f29b08e61bfa34c1e30c64aa59a6fed9c4c35aaca996fd0e8b728e839c24e74eae9f23ac3c99406361a061f0fa5dc04ce3ce9aa SHA512 47a2c26d3c45578cb2cbae96ec1b647298824d08584e2610aacd038e21069297a1f5b3366340cf781d29827555ff4d955651f70cdc2d36b99808fddf52e7a242
+DIST premake-5.0.0_alpha12.tar.gz 3548788 BLAKE2B 30f7b0e139ac8b7639c78b06ae139137d4f62b4a7690b180d6c292f57205e7ab352042241735f472d20163c24277b835e9b14e307d66602d5c1bc1a7c65da036 SHA512 6f458fada8af9d93e99f9511b0cf1a2cad87eacf155c8330cab9f830c89aac0ba137ea466b8b2ecfd4a104132c7cd79eefbd06b9780066d27760bc695a4b94a2
DIST premake-src-3.7.zip 427727 BLAKE2B 2f9cc7b045f75ceb52a8e71507cb5576f042a93be4f6c097e8bc1166e3bbb9e271a02f5fbd648f79e0d24867a09bba9ac72a268fdc47140219c5d6a36cda1a16 SHA512 351b26b9ee738e97b1828e7c26fe1538fb1509fbdc030da3d87fc28b1daa7966bc50ba8043062d35b37fa3929d909533b723241e1f98e438a039c6f9d61a46f4
diff --git a/dev-util/premake/premake-4.4_beta5.ebuild b/dev-util/premake/premake-4.4_beta5.ebuild
new file mode 100644
index 000000000000..68325bfb5d3b
--- /dev/null
+++ b/dev-util/premake/premake-4.4_beta5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/_/-}
+
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="https://premake.github.io/"
+SRC_URI="mirror://sourceforge/premake/${MY_P}-src.zip"
+
+LICENSE="BSD"
+SLOT=$(get_major_version)
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ sed 's/$(ARCH) //g' -i build/gmake.unix/Premake4.make || die
+}
+
+src_compile() {
+ emake -C build/gmake.unix/
+}
+
+src_install() {
+ dobin bin/release/premake${SLOT}
+
+ einstalldocs
+}
diff --git a/dev-util/premake/premake-5.0.0_alpha12.ebuild b/dev-util/premake/premake-5.0.0_alpha12.ebuild
new file mode 100644
index 000000000000..77ea240109ba
--- /dev/null
+++ b/dev-util/premake/premake-5.0.0_alpha12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/_/-}
+MY_PV=${PV/_/-}
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="https://premake.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}-core/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT=$(get_major_version)
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}-core-${MY_PV}"
+
+src_compile() {
+ emake -f Bootstrap.mak linux
+}
+
+src_test() {
+ bin/release/premake${SLOT} test || die
+}
+
+src_install() {
+ dobin bin/release/premake${SLOT}
+
+ einstalldocs
+}