summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-04-27 22:38:12 +0200
committerZac Medico <zmedico@gentoo.org>2020-05-17 16:41:15 -0700
commit24c273d478fbc7e430284f1914fc693e857b7e65 (patch)
tree1d903e6890eb3a9eee1ff59ee72f807c5804bddb /dev-util
parentdev-libs/libuv: Version 1.38.0 (diff)
downloadgentoo-24c273d478fbc7e430284f1914fc693e857b7e65.tar.gz
gentoo-24c273d478fbc7e430284f1914fc693e857b7e65.tar.bz2
gentoo-24c273d478fbc7e430284f1914fc693e857b7e65.zip
dev-util/ply: update to 2.1.1 and add new maintainers
Closes: https://github.com/gentoo/gentoo/pull/15545 Closes: https://bugs.gentoo.org/722744 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Luka Perkov <luka.perkov@sartura.hr> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ply/Manifest1
-rw-r--r--dev-util/ply/metadata.xml12
-rw-r--r--dev-util/ply/ply-2.1.1.ebuild32
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/ply/Manifest b/dev-util/ply/Manifest
index 481b15d0cd15..6438cf1567c9 100644
--- a/dev-util/ply/Manifest
+++ b/dev-util/ply/Manifest
@@ -1 +1,2 @@
DIST ply-0_pre20160313.tar.gz 38530 BLAKE2B 3c709e98c32cfd5dce389cf8829e135e0ecdc7907c83dcd2eed88c9c4c5f5a81093cc9ca7045b0cdb18566f0a8b49ddb4d3ba7320c7eaf56a350e45345e8d7bf SHA512 2de2ca2751574fe23b48188b0e8d1b4f1afe46003cbdefa69aeadaed0442675dad42b6cbfd161ebfbe006fbb21d447be4fca0ea7350b1409207473511f685d47
+DIST ply-2.1.1.tar.gz 71578 BLAKE2B b63d0bd355985035b8d1c934c13982e21eeda0d710f40b8131562e9ef6a21a3eaf04960b871f5ab83d718ab1726450996988a2aef1a6fbd2e8f1a3c55db92beb SHA512 fdc66d752989a239e01d2746e6c56610c2c945fbeeff8f2a79be1db487a6cbba365d1bd1b553d25c43a3fdc3634ab96bf4a37ab4f694c6eb6eba82c35b37231e
diff --git a/dev-util/ply/metadata.xml b/dev-util/ply/metadata.xml
index 0e1f3d58af2b..28ee2e30136d 100644
--- a/dev-util/ply/metadata.xml
+++ b/dev-util/ply/metadata.xml
@@ -4,6 +4,18 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="person">
+ <email>jakov.smolic@sartura.hr</email>
+ <name>Jakov Smolic</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>luka.perkov@sartura.hr</email>
+ <name>Luka Perkov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">iovisor/ply</remote-id>
</upstream>
diff --git a/dev-util/ply/ply-2.1.1.ebuild b/dev-util/ply/ply-2.1.1.ebuild
new file mode 100644
index 000000000000..d9e8cefdd72a
--- /dev/null
+++ b/dev-util/ply/ply-2.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools linux-info
+
+DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
+HOMEPAGE="https://github.com/iovisor/ply"
+SRC_URI="https://github.com/iovisor/ply/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+pkg_pretend() {
+ local CONFIG_CHECK="~BPF ~BPF_SYSCALL ~NET_CLS_BPF ~NET_ACT_BPF
+ ~BPF_JIT ~HAVE_BPF_JIT ~BPF_EVENTS"
+
+ check_extra_config
+}
+
+src_prepare() {
+ sed -i "/^AC_INIT/c\AC_INIT(${PN}, ${PV}," configure.ac || die
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${ED}/usr/share/doc/${P}/COPYING"
+}