summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-05-25 11:01:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-05-25 11:02:16 +0200
commit28d08e68fd9158db794c673346d652eeb42f8f3e (patch)
treeeabe272d8615841be20655b95dc047be01e139d2 /dev-util
parentmedia-gfx/graphviz: Version bump (v2.44) (diff)
downloadgentoo-28d08e68fd9158db794c673346d652eeb42f8f3e.tar.gz
gentoo-28d08e68fd9158db794c673346d652eeb42f8f3e.tar.bz2
gentoo-28d08e68fd9158db794c673346d652eeb42f8f3e.zip
dev-util/pkgconf: Bump to version 1.7.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.7.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index d82b487f694f..dbb333b701ba 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1 +1,2 @@
DIST pkgconf-1.6.3.tar.xz 291216 BLAKE2B 04bf58590e2f0b37bac7b24b3d595ad08680e85647548cbd642495398d95706f9f738af5c6f9b9ad8801567caa20ade85d4c4d74179f08313420683cb1b34263 SHA512 437c5a5c9866e2047e62e0592639930b2420d4afd41d98cef51f3475165418a39e916477860025314828a6ee0a4eefc10fdf26bda66f80c291f324d9674fa5c1
+DIST pkgconf-1.7.0.tar.xz 292420 BLAKE2B 2b709596c0ca8b62913a89fd6d3c4267f4f6f8585565dd66243d876a3b49795a522d3fced913d97cdaeb5cbad95b9655f2c23ef8160a03e68109fb4a21df8d90 SHA512 636741c11c35dbe39bbd38760268deefede2c312cb65ac1c20dbb2ce2c4eca884481e5888f5f6987c084f753684ff8d008713f7638952ea1d67a58ecce2fa05d
diff --git a/dev-util/pkgconf/pkgconf-1.7.0.ebuild b/dev-util/pkgconf/pkgconf-1.7.0.ebuild
new file mode 100644
index 000000000000..c5741a924750
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.7.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2012-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kaniini/pkgconf"
+else
+ SRC_URI="http://distfiles.dereferenced.org/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://git.sr.ht/~kaniini/pkgconf"
+
+LICENSE="ISC"
+SLOT="0/3"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ local ECONF_SOURCE="${S}"
+ econf --disable-static
+}
+
+multilib_src_test() {
+ unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
+ default
+}
+
+multilib_src_install() {
+ default
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
+ else
+ rm "${ED}"/usr/share/aclocal/pkg.m4 || die
+ rmdir "${ED}"/usr/share/aclocal || die
+ rm "${ED}"/usr/share/man/man7/pkg.m4.7 || die
+ rmdir "${ED}"/usr/share/man/man7 || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}