summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-04 17:15:34 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-04 17:15:52 -0400
commit6d9cbada4bb926777efe07a18021ccfa52732d32 (patch)
tree3dfdfaacbe27aa755e84a4799f14bb885fbede1f /dev-util
parentsys-apps/firejail: Correct deps for X11 (diff)
downloadgentoo-6d9cbada4bb926777efe07a18021ccfa52732d32.tar.gz
gentoo-6d9cbada4bb926777efe07a18021ccfa52732d32.tar.bz2
gentoo-6d9cbada4bb926777efe07a18021ccfa52732d32.zip
dev-util/catalyst: version bump to 2.0.18-r4, bug #584234
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catalyst/catalyst-2.0.18-r4.ebuild121
-rw-r--r--dev-util/catalyst/files/catalyst-2.0.18-stage1-export-ROOT.patch42
2 files changed, 163 insertions, 0 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.18-r4.ebuild b/dev-util/catalyst/catalyst-2.0.18-r4.ebuild
new file mode 100644
index 000000000000..39728ec3f798
--- /dev/null
+++ b/dev-util/catalyst/catalyst-2.0.18-r4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == *9999* ]]; then
+ SRC_ECLASS="git-2"
+ EGIT_REPO_URI="anongit.gentoo.org/proj/catalyst.git"
+ EGIT_MASTER="master"
+ S="${WORKDIR}/${PN}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ https://dev.gentoo.org/~jmbsvicetto/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~mattst88/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.bz2
+ https://dev.gentoo.org/~dolsen/releases/catalyst/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 ${SRC_ECLASS}
+
+DESCRIPTION="Release metatool used for creating releases based on Gentoo Linux"
+HOMEPAGE="https://www.gentoo.org/proj/en/releng/catalyst/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ccache kernel_linux"
+
+DEPEND="
+ app-text/asciidoc
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ app-arch/lbzip2
+ app-crypt/shash
+ app-arch/tar[xattr]
+ virtual/cdrtools
+ amd64? ( >=sys-boot/syslinux-3.72 )
+ ia64? ( sys-fs/dosfstools )
+ x86? ( >=sys-boot/syslinux-3.72 )
+ ccache? ( dev-util/ccache )
+ kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )
+ ${PYTHON_DEPS}
+"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+PATCHES=(
+ "${FILESDIR}/catalyst-2.0.18-Do-notuntarwith--acls.patch"
+ "${FILESDIR}/catalyst-2.0.18-fix-quotes.patch"
+ "${FILESDIR}/catalyst-2.0.18-remove-machine-id.patch"
+ "${FILESDIR}/catalyst-2.0.18-stage1-export-ROOT.patch"
+)
+
+pkg_setup() {
+ if use ccache ; then
+ einfo "Enabling ccache support for catalyst."
+ else
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+
+ echo
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
+ echo
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/${PN}
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe catalyst || die "copying catalyst"
+
+ if [[ ${PV} == 3.9999* ]]; then
+ doins -r modules files || die "copying files"
+ else
+ doins -r arch modules livecd || die "copying files"
+ fi
+
+ for x in targets/*; do
+ exeinto /usr/$(get_libdir)/${PN}/$x
+ doexe $x/* || die "copying ${x}"
+ done
+
+ # Here is where we actually enable ccache
+ use ccache && \
+ sed -i -e 's:options="autoresume kern:options="autoresume ccache kern:' \
+ files/catalyst.conf
+
+ sed -i -e "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
+ files/catalyst.conf
+
+ make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
+ insinto /etc/catalyst
+ doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
+ dodoc README AUTHORS
+ doman files/catalyst.1 files/catalyst-spec.5
+
+ python_fix_shebang "${ED}usr/$(get_libdir)/catalyst/catalyst"
+ python_optimize "${ED}"
+}
+
+pkg_postinst() {
+ einfo "You can find more information about catalyst by checking out the"
+ einfo "catalyst project page at:"
+ einfo "https://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0.18-stage1-export-ROOT.patch b/dev-util/catalyst/files/catalyst-2.0.18-stage1-export-ROOT.patch
new file mode 100644
index 000000000000..67fc2c631b02
--- /dev/null
+++ b/dev-util/catalyst/files/catalyst-2.0.18-stage1-export-ROOT.patch
@@ -0,0 +1,42 @@
+From 5fd2d5edd3c4c1e99687beb9acc130bab162866b Mon Sep 17 00:00:00 2001
+From: "Anthony G. Basile" <blueness@gentoo.org>
+Date: Sat, 4 Jun 2016 12:43:44 -0400
+Subject: stage1-preclean-chroot.sh: export ROOT=/tmp/stage1root for
+ setup_gcc()
+
+setup_gcc() calls gcc-config to select a particular gcc profile. At stage1 this
+needs to be done in the /tmp/stage1root chroot. gcc-config looks for ROOT to
+choose the root directory in which to make the selection. If we don't export
+ROOT, then setup_gcc is ineffective.
+
+X-Gentoo-Bug: 584234
+X-Gentoo-Bug-Url: https://bugs.gentoo.org/show_bug.cgi?id=584234
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+---
+ targets/stage1/stage1-preclean-chroot.sh | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/targets/stage1/stage1-preclean-chroot.sh b/targets/stage1/stage1-preclean-chroot.sh
+index a80fc92..dc67521 100755
+--- a/targets/stage1/stage1-preclean-chroot.sh
++++ b/targets/stage1/stage1-preclean-chroot.sh
+@@ -1,5 +1,6 @@
+ #!/bin/bash
+
++export ROOT=/tmp/stage1root
+ export RUN_DEFAULT_FUNCS="no"
+
+ source /tmp/chroot-functions.sh
+@@ -8,8 +9,6 @@ update_env_settings
+ show_debug
+
+ # Now, some finishing touches to initialize gcc-config....
+-unset ROOT
+-
+ setup_gcc
+ setup_binutils
+
+--
+cgit v0.12
+