summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-15 13:38:05 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-15 13:38:05 +0200
commit7ebbb6c2c33b896683fe6f1fe63ea80a97d34238 (patch)
treec15b2c65655cc8ac136995bd1c785de0c13c0752 /dev-util
parentsys-apps/yarn: Version bump to 1.0.2 (diff)
downloadgentoo-7ebbb6c2c33b896683fe6f1fe63ea80a97d34238.tar.gz
gentoo-7ebbb6c2c33b896683fe6f1fe63ea80a97d34238.tar.bz2
gentoo-7ebbb6c2c33b896683fe6f1fe63ea80a97d34238.zip
dev-util/pycharm-community: Version bump to 2017.2.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pycharm-community/Manifest1
-rw-r--r--dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-util/pycharm-community/Manifest b/dev-util/pycharm-community/Manifest
index 5f6c3a9e2bcb..dfee0d36b746 100644
--- a/dev-util/pycharm-community/Manifest
+++ b/dev-util/pycharm-community/Manifest
@@ -3,3 +3,4 @@ DIST pycharm-community-2017.1.3.tar.gz 195297254 SHA256 6dedbf06c62490047b5d8a53
DIST pycharm-community-2017.1.5.tar.gz 195342869 SHA256 1a0bbf0d881527e08aad7a5adaa3ad44e8754c3eb2c3a8ed5ab113491549679b SHA512 1eac6062a1b92782e50425e053ec326965eaff6bf36ec3cf6d4e9fcdc1fe1a8baaf4d16131a38fc506c55c384943aaea51cf5f4c9d8d2e36080b7342ef1af21c WHIRLPOOL 1a655bcaa78b4a6607601229455e822cc56341c70132363a57cb9f6597f9f31ce007426a70284467cfe2c1a082972883746957e67dc678b5d379956f46a6c3cf
DIST pycharm-community-2017.1.tar.gz 195354973 SHA256 6669120b68873a0bcb7faf179ea79f7c2dd7eac34d377d1f574724604b70e692 SHA512 056b23ba8b6cda4d609a2011b18e207f470670048185afeff0ad18dff8093d0ff0efa20a0a20b020ce81bc23008a31c7c9620c7fb4dc1f7e3d3b62316005322c WHIRLPOOL 0fefc16a433d41d64034a2df057a27bd035ec92cc7e00246f93a1afc0ef2350e919018071781e87d6285526993997507616f01f310e8c308bc4a1552b3eb4ef3
DIST pycharm-community-2017.2.1.tar.gz 200410040 SHA256 4a7e5ab8c89be6ac3b6da649003260d1ed86b1dd41b7e9aa1d3873cacd7d6bd1 SHA512 734cbe66b38970a6f0c7e14d25f73143074d75034f6a29907c33998c3f83142f18f0016350916577db4497356594f144c7499f73c6a2e53e80374b3bf387f4f3 WHIRLPOOL 7dc075e2ce63dabb5eaca9a2b390d5930330ad39964b0d9e3d6ab935c141c1627696fd8f72bc862c3e684c9a454f9e3c21dd630673f01ff0909dd4c0cf01a3c8
+DIST pycharm-community-2017.2.3.tar.gz 200478376 SHA256 e8562938c2ede32a1c1036391942190144cd9f0927bd49b6b3ddf5f7a01c33aa SHA512 502b056f15367c0aaed2a2b001b218f2f7e48d65b313d7560f3b77a0337a2502628ee502cb730eb2f8c6c853460988760e10601b98d43936603afa80beb1065e WHIRLPOOL 4096a3afcf86ae17e8021783c55264625e80a87034eaf6b0612fd622f88d52d24d7c27388be0c7f9a78b21333762fcf0531bd8f17b5cd4b2849cee5298d2f831
diff --git a/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild b/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild
new file mode 100644
index 000000000000..6bcb19218d4c
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-2017.2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils readme.gentoo-r1
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
+DEPEND=""
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+ opt/${PN}/bin/fsnotifier64
+ opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+ default
+
+ rm -rf jre || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_create_doc
+}