summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-01-09 03:04:14 +0100
committerMichael Weber <xmw@gentoo.org>2016-01-09 03:06:13 +0100
commit8ef6ba279be7191fc99ab27146a6f8fc1ee901de (patch)
tree9c118c82efc08bdd65bec1d991899c63d92faeda /dev-util
parentwww-client/jumanji: Fix EGIT_REPO_URI (thanks tharvik@gmail.com, bug 566890). (diff)
downloadgentoo-8ef6ba279be7191fc99ab27146a6f8fc1ee901de.tar.gz
gentoo-8ef6ba279be7191fc99ab27146a6f8fc1ee901de.tar.bz2
gentoo-8ef6ba279be7191fc99ab27146a6f8fc1ee901de.zip
dev-util/cppcheck: Version bump (thanks Christian Strahl, bug 566974).
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/Manifest1
-rw-r--r--dev-util/cppcheck/cppcheck-1.71.ebuild106
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.71-tinyxml2.patch67
3 files changed, 174 insertions, 0 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index 237e644cd36f..4c36b9726b34 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,2 +1,3 @@
DIST cppcheck-1.69.tar.bz2 1052984 SHA256 4bd5c8031258ef29764a4c92666384238a625beecbb2aceeb7065ec388c7532e SHA512 30f239bcdf4cb1fcc254271bf55f3fdc1ec22e7d26f0704218390cfce1d4cf3ef41f385f4e463ede1a1a401e87d81b1d66a462c7b07e045d46aebd2354384a01 WHIRLPOOL e341c8b8f133fd19188700d53d6f02ab5deffc10fdfedbc9474931596850c10027a91e445998a3884f8f30908581e428fe4c629397b14660a0fe7b852e48b3a4
DIST cppcheck-1.70.tar.bz2 1111291 SHA256 c6aaafd41b4c2050f3fb96a4aa159507007403a163d05361bd9544e5baf18f39 SHA512 c2223edce22739e555eca114bc39d8f66229ec26fb122c976e3dcf88957bfd6b37c170e183f22611ea2d17ac22b33da78440f820c044f6099ac901bd6c4f1b8d WHIRLPOOL 0b6c52d13ff8c9c8dfdf383e419edd311a484a89d695dbf9409f1ea608c1dc5bbc20fcb03bc0469495a35b61a43a90ccf1e76cd191cf28326f929020d66083b6
+DIST cppcheck-1.71.tar.bz2 1128689 SHA256 0114d29e5c49c8ff0030798f4fa02f9ef4c1d64d09697a3ea4b19aa5b67b4afe SHA512 ff56909ca566f9a48623822d78119930f0f55961a8011b0bce92178b25f82649847612157fa24f3b21f0aad6da81aa8387d08f7af4127df1d5a75b20ced67af9 WHIRLPOOL 2d1ff247c85354329bc645a8d74ae16119e6a246a282cb47e119a956d7d65bb4ea9fd3964a228b45a11cfa5efacc6fc8ae4602c29256f237c687d35da8c154c5
diff --git a/dev-util/cppcheck/cppcheck-1.71.ebuild b/dev-util/cppcheck/cppcheck-1.71.ebuild
new file mode 100644
index 000000000000..f126c41158cf
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.71.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 eutils flag-o-matic qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://cppcheck.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="htmlreport pcre qt4"
+
+RDEPEND="htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
+ >=dev-libs/tinyxml2-2
+ qt4? ( dev-qt/qtgui:4 )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig"
+
+src_prepare() {
+ append-cxxflags -std=c++0x
+
+ # Drop bundled libs, patch Makefile generator and re-run it
+ rm -r externals || die
+ epatch "${FILESDIR}"/${PN}-1.71-tinyxml2.patch
+ tc-export CXX
+ emake dmake
+ ./dmake || die
+
+ epatch_user
+}
+
+src_configure() {
+ if use pcre ; then
+ sed -e '/HAVE_RULES=/s:=no:=yes:' \
+ -i Makefile
+ fi
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ export LIBS="$(pkg-config --libs tinyxml2)"
+ emake ${PN} man \
+ CFGDIR="${EROOT}usr/share/${PN}/cfg" \
+ DB2MAN="${EROOT}usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl" \
+ CXXFLAGS="${CXXFLAGS} -std=c++0x"
+
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_test() {
+ # safe final version
+ mv -v ${PN}{,.final}
+ mv -v lib/library.o{,.final}
+ mv -v cli/cppcheckexecutor.o{,.final}
+ #trigger recompile with CFGDIR inside ${S}
+ emake check CFGDIR="${S}/cfg"
+ # restore
+ mv -v ${PN}{.final,}
+ mv -v lib/library.o{.final,}
+ mv -v cli/cppcheckexecutor.o{.final,}
+}
+
+src_install() {
+ # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
+ emake install DESTDIR="${ED}"
+
+ insinto "/usr/share/${PN}/cfg"
+ doins cfg/*.cfg
+ if use qt4 ; then
+ dobin gui/${PN}-gui
+ dodoc gui/{projectfile.txt,gui.${PN}}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_install
+ popd
+ find "${D}" -name "*.egg-info" -delete
+ else
+ rm "${ED}/usr/bin/cppcheck-htmlreport" || die
+ fi
+ doman ${PN}.1
+ dodoc -r triage
+}
diff --git a/dev-util/cppcheck/files/cppcheck-1.71-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.71-tinyxml2.patch
new file mode 100644
index 000000000000..4b82c21e0f66
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-1.71-tinyxml2.patch
@@ -0,0 +1,67 @@
+--- cppcheck-1.71/gui/gui.pro
++++ cppcheck-1.71/gui/gui.pro
+@@ -14,7 +14,7 @@
+ LIBS += -l../bin/cppcheck-core
+ DEFINES += CPPCHECKLIB_IMPORT
+ }
+-LIBS += -L$$PWD/../externals
++LIBS += `pkg-config --libs tinyxml2`
+
+ DESTDIR = .
+ RCC_DIR = temp
+--- cppcheck-1.71/tools/dmake.cpp
++++ cppcheck-1.71/tools/dmake.cpp
+@@ -174,7 +174,6 @@
+ }
+
+ std::vector<std::string> externalfiles;
+- getCppFiles(externalfiles, "externals/", true);
+
+
+ // QMAKE - lib/lib.pri
+@@ -183,10 +182,6 @@
+ if (fout1.is_open()) {
+ fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
+ fout1 << "include($$PWD/pcrerules.pri)\n";
+- fout1 << "BASEPATH = ../externals/tinyxml/\n";
+- fout1 << "include($$PWD/../externals/tinyxml/tinyxml.pri)\n";
+- fout1 << "BASEPATH = ../lib/\n";
+- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
+ fout1 << "HEADERS += $${BASEPATH}check.h \\\n";
+ for (unsigned int i = 0; i < libfiles.size(); ++i) {
+ std::string fname(libfiles[i].substr(4));
+@@ -212,7 +207,6 @@
+ std::ofstream fout1("test/testfiles.pri");
+ if (fout1.is_open()) {
+ fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
+- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
+ fout1 << "\n\nSOURCES += ";
+ for (unsigned int i = 0; i < testfiles.size(); ++i) {
+ const std::string filename(testfiles[i].substr(5));
+@@ -376,9 +370,9 @@
+ << "endif\n\n";
+
+ makeConditionalVariable(fout, "PREFIX", "/usr");
+- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -Iexternals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -Iexternals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -Iexternals/tinyxml");
++ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib");
++ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib");
++ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli");
+
+ fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
+ fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
+@@ -419,10 +413,10 @@
+ fout << "\t$(CXX) $(CXXFLAGS) -o dmake tools/dmake.o cli/filelister.o cli/pathmatch.o lib/path.o -Ilib $(LDFLAGS)\n\n";
+ fout << "run-dmake: dmake\n";
+ fout << "\t./dmake\n\n";
+- fout << "reduce:\ttools/reduce.o externals/tinyxml/tinyxml2.o $(LIBOBJ)\n";
+- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -g -o reduce tools/reduce.o -Ilib -Iexternals/tinyxml $(LIBOBJ) $(LIBS) externals/tinyxml/tinyxml2.o $(LDFLAGS) $(RDYNAMIC)\n\n";
++ fout << "reduce:\ttools/reduce.o $(LIBOBJ)\n";
++ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o reduce tools/reduce.o -Ilib $(LIBOBJ) $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
+ fout << "clean:\n";
+- fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o tools/*.o externals/tinyxml/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
++ fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o tools/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
+ fout << "man:\tman/cppcheck.1\n\n";
+ fout << "man/cppcheck.1:\t$(MAN_SOURCE)\n\n";
+ fout << "\t$(XP) $(DB2MAN) $(MAN_SOURCE)\n\n";