summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-01-21 20:44:55 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-01-22 22:49:18 +0100
commit99e7056544f4ce113a5ddff688de0c3a51504f7a (patch)
treefc7af94e91665aa63d787f97a5fc2715473aa0a3 /dev-util
parentdev-php/composer: version bump to 1.6.2. (diff)
downloadgentoo-99e7056544f4ce113a5ddff688de0c3a51504f7a.tar.gz
gentoo-99e7056544f4ce113a5ddff688de0c3a51504f7a.tar.bz2
gentoo-99e7056544f4ce113a5ddff688de0c3a51504f7a.zip
dev-util/vint: verbump to 0.3.18.
Package-Manager: Portage-2.3.20, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6924
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/vint/Manifest1
-rw-r--r--dev-util/vint/vint-0.3.18.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
index 2d291a29f5d7..0e5d1cd46098 100644
--- a/dev-util/vint/Manifest
+++ b/dev-util/vint/Manifest
@@ -1,2 +1,3 @@
DIST vint-0.3.13.tar.gz 91599 BLAKE2B 7cc9a6aca8cbd259d3ff79659c38e3d51b5f0ba75a7485872fd922543d75867fcc1689b0f7f8915e3195905b47bb0a467d9646bcb29082e9c04a1557e19b3717 SHA512 ef0b811df0250899e23e30ee4b240cf8b54e510231353ca86202661fd5f0826b9faeacc9268849e51bd6a1c71c1514498dec04a7a4ed79f00a5098811525e3d4
DIST vint-0.3.17.tar.gz 95358 BLAKE2B 102840bc2311148af5c20499c65417459d1abcdcaae0b95bd0bbb3e1569f98f0f0abb30ccae653aff844750efa340fc38a0f8905ee70b3aec8fdc5a8fcc0a6f6 SHA512 c3df61d47b4adf68ecfb8903ea0c030acbba3e72ce95514ef25823a5321181ebbf783c1a76613de9927acefb088edd890a0a776b40888cca62b2063e436820e6
+DIST vint-0.3.18.tar.gz 95865 BLAKE2B 0f7e61b720aa0998091b9b40118b199392fbf1aeace8801d683e8249179cd3d792e15b42df6d34c567c4df1830629a80e6043e87092f37dc46a0e57c6a56cf53 SHA512 1d3e04527a8f5ffae29395010a88258c1771aff2798143eff6572400eaf96323cad04353a7fcee68d9407afde5808446f515fd3d7e8e62de4bef28edf214ebdd
diff --git a/dev-util/vint/vint-0.3.18.ebuild b/dev-util/vint/vint-0.3.18.ebuild
new file mode 100644
index 000000000000..00895d88442f
--- /dev/null
+++ b/dev-util/vint/vint-0.3.18.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.python.org/pypi/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Don't try to use an installed vint executable.
+ # See https://github.com/Kuniwak/vint/issues/22
+ sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
+}
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}