summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-07-19 11:46:08 -0400
committerCraig Andrews <candrews@gentoo.org>2019-07-19 11:47:10 -0400
commite4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2 (patch)
tree85d42f0df1fe67602cd4cc0c8050691ccf7c1b31 /dev-util
parentdev-util/conf2struct: Disable parallel make (diff)
downloadgentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.tar.gz
gentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.tar.bz2
gentoo-e4ba8f5a8fa699b615f406bd7f4b4f5ef7a736a2.zip
dev-util/conf2struct: Respect CFLAGS and CC
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild43
-rw-r--r--dev-util/conf2struct/conf2struct-9999.ebuild4
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild b/dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild
new file mode 100644
index 000000000000..b31468b61ccd
--- /dev/null
+++ b/dev-util/conf2struct/conf2struct-0_pre0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="Create C parsers for libconfig and command-line"
+HOMEPAGE="https://github.com/yrutschle/conf2struct/"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/yrutschle/conf2struct.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ GIT_COMMIT="10ea3356b65e712fb000f4d37f00e1dc09c1e722"
+ SRC_URI="https://github.com/yrutschle/conf2struct/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${GIT_COMMIT}"
+fi
+
+PATCHES=(
+ "${FILESDIR}/${P}-install-and-uninstall.patch"
+ "${FILESDIR}/${P}-cc-and-cflags.patch"
+ "${FILESDIR}/${P}-destdir.patch"
+ "${FILESDIR}/${P}-install-not-run-all.patch"
+ "${FILESDIR}/${P}-dest-exists.patch"
+)
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/libconfig
+ dev-perl/Conf-Libconfig"
+DEPEND="${RDEPEND}"
+
+src_compile(){
+ # -j1 due to parallel make issue reported upstream at: https://github.com/yrutschle/conf2struct/issues/10
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install(){
+ emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
+}
diff --git a/dev-util/conf2struct/conf2struct-9999.ebuild b/dev-util/conf2struct/conf2struct-9999.ebuild
index f20edc27e4db..b853d93f1b86 100644
--- a/dev-util/conf2struct/conf2struct-9999.ebuild
+++ b/dev-util/conf2struct/conf2struct-9999.ebuild
@@ -23,6 +23,10 @@ RDEPEND="dev-libs/libconfig
dev-perl/Conf-Libconfig"
DEPEND="${RDEPEND}"
+src_compile(){
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
src_install(){
emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
}