summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:33:48 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-16 09:41:39 -0800
commite74a8fd6efafc3fdd19f5c025e06589e5016f1b5 (patch)
tree8c4083a60d8f4d163645036f5e1b2a203027cb31 /dev-util
parentdev-util/buildbot-console-view: Version bump (diff)
downloadgentoo-e74a8fd6efafc3fdd19f5c025e06589e5016f1b5.tar.gz
gentoo-e74a8fd6efafc3fdd19f5c025e06589e5016f1b5.tar.bz2
gentoo-e74a8fd6efafc3fdd19f5c025e06589e5016f1b5.zip
dev-util/buildbot-grid-view: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot-grid-view/Manifest1
-rw-r--r--dev-util/buildbot-grid-view/buildbot-grid-view-0.9.15_p1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/buildbot-grid-view/Manifest b/dev-util/buildbot-grid-view/Manifest
index d514855270fb..518b93ad5304 100644
--- a/dev-util/buildbot-grid-view/Manifest
+++ b/dev-util/buildbot-grid-view/Manifest
@@ -1,3 +1,4 @@
DIST buildbot-grid-view-0.9.11.tar.gz 638818 BLAKE2B 532f13d53440f436252968cde78275aed1cbb4b4e6348c59be8e9d14780f9cdc8bce2655b77a563847b7a7275ec9749b67072f34923f17d2c702be466eb020a2 SHA512 4da052b284452557a1de080afd31064b8ae950f1a1fbe2f2418a130e1150b84fc25a119866ccc5889a38dfe94a5f1f8d3b4ff7f3f7dd6cdb485eea90adda3f2a
DIST buildbot-grid-view-0.9.12.post1.tar.gz 638819 BLAKE2B 5e0bdc39ebe2b447b23abaddc414713c46e5544915d5564641a0534dfa9862f71d689c5df27a5f2a6ecbaa33c29ece5bc85e1c2d1f0a10b0f19273364699748f SHA512 3bc90dcee10781afa90a44d0ff57629f2fe8620fb1133a489282b3a69b884d33a7ad3cbf6e38f688755fcc2153c9ae1c0d48cd2797e33070f66a9093887179c6
DIST buildbot-grid-view-0.9.13.tar.gz 639145 BLAKE2B 31194a53bdb60958178371e10fd2ed0ca05d112d9a3510147d965811bb31788bd432ad1ed1c4690f190070ec5dc683cc43ed8a187b26eec5b80b7f23663e7418 SHA512 2ae54f27cafdf1e4d5c283bbe60db8bcc38d3ec133069114bfa952ae2f49306c7a83d57fd4749eb923567e22fdb0577311532ef45eb8630fe01a7c3fea6e2cef
+DIST buildbot-grid-view-0.9.15.post1.tar.gz 638877 BLAKE2B 7ef5a309bebb1fed0ff1b0efd016c9d895b44a03d0c3743690d6fc04ab669d6409af93be62ffa1ef0cac9465ef7940b48984ab423a22023800211514335d8011 SHA512 741dc6ef728f291d44663bb6f031fd0895b67bb770db053695bf276ae3a6a0f2e6e73eae7c595befec2f917e766b13913486331297cb048f000a124916ff6405
diff --git a/dev-util/buildbot-grid-view/buildbot-grid-view-0.9.15_p1.ebuild b/dev-util/buildbot-grid-view/buildbot-grid-view-0.9.15_p1.ebuild
new file mode 100644
index 000000000000..384073a7a830
--- /dev/null
+++ b/dev-util/buildbot-grid-view/buildbot-grid-view-0.9.15_p1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="BuildBot grid view web interface"
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-grid-view"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+
+IUSE="test"
+
+RDEPEND=""
+
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+ =dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+ =dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}