summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/git-bzr-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/git-bzr-ng')
-rw-r--r--dev-vcs/git-bzr-ng/Manifest2
-rw-r--r--dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120130.ebuild39
-rw-r--r--dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild39
-rw-r--r--dev-vcs/git-bzr-ng/metadata.xml12
4 files changed, 92 insertions, 0 deletions
diff --git a/dev-vcs/git-bzr-ng/Manifest b/dev-vcs/git-bzr-ng/Manifest
new file mode 100644
index 000000000000..fe1975188cbc
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/Manifest
@@ -0,0 +1,2 @@
+DIST git-bzr-ng-0_pre20120130.tar.xz 11596 SHA256 cdfee5b8a9d6bb5980123a00933f71de8e38fe36d3a3ce57a2a92eae1b4ba5fc SHA512 2621d60889fdae75d2fd291e4ef628f888524d6c5cd48b3fae8ac793984d3d58b47da2ca38477e1154714de7316992a879cae21103636e68f4ae0cd03de7bcc8 WHIRLPOOL e06dcf9caaa8cc455447d3956b311d7a69f5dc898e526b68abf0589ce371c956c8633935caa5554f1e9b2ec41c449e394b6815bff24452e13913c70456deff79
+DIST git-bzr-ng-0_pre20120822.tar.xz 11592 SHA256 315d7d567ef173d7a8e2f17304bd73a1f6779cd754e6d4ea67f48bd5d75a55ec SHA512 2652b76a1fbdfac7f7387b53167d0c76a0579e232f66be05c28a156eef638e40bd7548154e6c1853872cf6978b474b948396db176976f2ac15e7311fc731ba9b WHIRLPOOL 783da6136a4a4f1fb95ca39b285b58bac2499c23ddec82f11468fba7d4303700ac388c5decb023e61964cda8a06d77420518ffdbef0d6871081ba8be0dd8bf80
diff --git a/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120130.ebuild b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120130.ebuild
new file mode 100644
index 000000000000..1891c6aca569
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120130.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
+HOMEPAGE="https://github.com/termie/git-bzr-ng"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/bzr-2.2
+ dev-vcs/git
+ >=dev-vcs/bzr-fastimport-0.10
+ dev-python/python-fastimport"
+DEPEND="app-arch/xz-utils"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 git-bzr
+}
+
+src_install() {
+ exeinto /usr/libexec/git-core
+ doexe git-bzr
+ dodoc README.rst
+}
diff --git a/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild
new file mode 100644
index 000000000000..1891c6aca569
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/git-bzr-ng-0_pre20120822.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Git subcommand providing a bidirectional bridge to Bazaar repositories"
+HOMEPAGE="https://github.com/termie/git-bzr-ng"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-vcs/bzr-2.2
+ dev-vcs/git
+ >=dev-vcs/bzr-fastimport-0.10
+ dev-python/python-fastimport"
+DEPEND="app-arch/xz-utils"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 git-bzr
+}
+
+src_install() {
+ exeinto /usr/libexec/git-core
+ doexe git-bzr
+ dodoc README.rst
+}
diff --git a/dev-vcs/git-bzr-ng/metadata.xml b/dev-vcs/git-bzr-ng/metadata.xml
new file mode 100644
index 000000000000..42972bdb6b29
--- /dev/null
+++ b/dev-vcs/git-bzr-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <herd>bazaar</herd>
+ <upstream>
+ <remote-id type="github">termie/git-bzr-ng</remote-id>
+ </upstream>
+</pkgmetadata>