summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2016-07-05 14:14:27 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2016-07-05 14:25:31 +0200
commite63b113e155e35be3e50875f8407a6e32f057e3d (patch)
tree8c1dcbf65115fe8b19b8b00b1118a99d2b9df107 /dev-vcs/git-deps
parentmail-mta/opensmtpd: bring back makemap and newaliases (diff)
downloadgentoo-e63b113e155e35be3e50875f8407a6e32f057e3d.tar.gz
gentoo-e63b113e155e35be3e50875f8407a6e32f057e3d.tar.bz2
gentoo-e63b113e155e35be3e50875f8407a6e32f057e3d.zip
dev-vcs/git-deps: Added instructions for html pages
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-vcs/git-deps')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
index 30589529d240..b42af867ac90 100644
--- a/dev-vcs/git-deps/git-deps-9999.ebuild
+++ b/dev-vcs/git-deps/git-deps-9999.ebuild
@@ -9,7 +9,7 @@ EGIT_BRANCH=master
PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-inherit git-r3 python-r1
+inherit eutils git-r3 python-r1
DESCRIPTION="git commit dependency analysis tool"
HOMEPAGE="https://github.com/aspiers/git-deps"
@@ -26,10 +26,19 @@ RDEPEND="
DEPEND="${RDEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+HTML_DOCS="html/."
+
src_install() {
python_foreach_impl python_newexe git-deps.py git-deps
+ einstalldocs
}
pkg_postinst() {
- einfo "Please run 'npm install browserify' to use git-deps with the web UI."
+ elog "Notes regarding the '--serve' option:"
+ elog "Please run 'npm install browserify' once"
+ elog "Copy the html sources:"
+ elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
+ elog "cd ~/git-deps-html"
+ elog "npm install"
+ elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
}