summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-08 13:53:51 +0100
committerSam James <sam@gentoo.org>2022-10-08 13:53:51 +0100
commit5a47c318896f1074a1d55beec2a3774eb459af61 (patch)
tree01cea00e36729102c31fce4bed2fb7740184ee92 /dev-vcs/git-extras
parentdev-libs/libgpg-error: add 1.46 (diff)
downloadgentoo-5a47c318896f1074a1d55beec2a3774eb459af61.tar.gz
gentoo-5a47c318896f1074a1d55beec2a3774eb459af61.tar.bz2
gentoo-5a47c318896f1074a1d55beec2a3774eb459af61.zip
dev-vcs/git-extras: add 6.5.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/git-extras')
-rw-r--r--dev-vcs/git-extras/Manifest1
-rw-r--r--dev-vcs/git-extras/files/git-extras-6.5.0-no-bash-completion-install.patch20
-rw-r--r--dev-vcs/git-extras/git-extras-6.5.0.ebuild51
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-vcs/git-extras/Manifest b/dev-vcs/git-extras/Manifest
index d877cdeed14e..676a43dea2a9 100644
--- a/dev-vcs/git-extras/Manifest
+++ b/dev-vcs/git-extras/Manifest
@@ -1 +1,2 @@
DIST git-extras-6.4.0.tar.gz 163508 BLAKE2B bffbc8efcf1cf030bceb20b953e1cbbc067c8383ced38b786c21eb9bd9b7d3febd3d8aae652c0dd731de688d3cfa225c3aec91d6b9c590459b576db113ca0af0 SHA512 1b28d09d294f6d060b7639401e56c8d5e762614b5f6928ee6267e49af943e349e2399558ebac60008e8240218c13f00f8aea7dc07b71fec1e2dc25487bc847a3
+DIST git-extras-6.5.0.tar.gz 167015 BLAKE2B 44331744399f55f9c6bba26bd0eef95e87a5b8ed0a216f3a4a71397fd2ac7aad4325ef787e1970f54c5b8732d0d291c20d6103c8549f3a1eb315bd7fe884337e SHA512 1dbf350ab822f5317d57ca7b90b914a71d3ad83746a79a369e221d20ade606b07a8b0f702610f50d1551c5c3ca12517df18106c6066745b40bf966052bbe9a46
diff --git a/dev-vcs/git-extras/files/git-extras-6.5.0-no-bash-completion-install.patch b/dev-vcs/git-extras/files/git-extras-6.5.0-no-bash-completion-install.patch
new file mode 100644
index 000000000000..f266c1562d91
--- /dev/null
+++ b/dev-vcs/git-extras/files/git-extras-6.5.0-no-bash-completion-install.patch
@@ -0,0 +1,20 @@
+We shouldn't install this manually to that location.
+--- a/Makefile
++++ b/Makefile
+@@ -69,8 +69,6 @@ install: check
+ cp -f man/git-*.1 $(DESTDIR)$(MANPREFIX); \
+ echo "cp -f man/git-*.1 $(DESTDIR)$(MANPREFIX)"; \
+ fi
+- @mkdir -p $(DESTDIR)$(SYSCONFDIR)/bash-completion/completions
+- cp -f etc/bash_completion.sh $(DESTDIR)$(SYSCONFDIR)/bash-completion/completions/git-extras
+ @echo ""
+ @echo "If you are a zsh user, you may want to 'source $(CODE_DIR)etc/git-extras-completion.zsh'" \
+ "and put this line into ~/.zshrc to enable zsh completion"
+@@ -119,7 +117,6 @@ uninstall:
+ echo "... uninstalling $(DESTDIR)$(MANPREFIX)/$(notdir $(MAN))"; \
+ rm -f $(DESTDIR)$(MANPREFIX)/$(notdir $(MAN)); \
+ )
+- rm -f $(DESTDIR)$(SYSCONFDIR)/bash-completion/completions/git-extras
+
+ clean: docclean
+
diff --git a/dev-vcs/git-extras/git-extras-6.5.0.ebuild b/dev-vcs/git-extras/git-extras-6.5.0.ebuild
new file mode 100644
index 000000000000..876db89e90ea
--- /dev/null
+++ b/dev-vcs/git-extras/git-extras-6.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Git utilities -- repo summary, repl, changelog population, and many more"
+HOMEPAGE="https://github.com/tj/git-extras"
+SRC_URI="https://github.com/tj/git-extras/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos"
+
+RDEPEND="
+ app-shells/bash
+ dev-vcs/git
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.5.0-no-bash-completion-install.patch
+)
+
+src_prepare() {
+ default
+
+ # For now, don't force including the git completion
+ # sed -i -e "1 i source $(get_bashcompdir)\/git" etc/bash_completion.sh || die
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc" \
+ install
+
+ # TODO: Unfortunately, none of the completion seems to
+ # actually work for me yet(?)
+
+ #newbashcomp "${S}"/etc/bash_completion.sh ${PN}
+
+ #insinto /usr/share/zsh/site-functions
+ #newins "${S}"/etc/${PN}-completion.zsh _${PN}
+
+ #insinto /usr/share/fish/vendor_completions.d
+ #doins "${S}"/etc/${PN}.fish
+}