summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-08 12:14:03 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-08 12:57:42 -0500
commit68452c97485ce39e9639b16816740e7ace19eb3b (patch)
treef6cf58cbddfc439df392ab1199abe2570f34cdf8 /dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild
parentdev-python/pygame_sdl2: bump to EAPI 6, add maintainer-needed (diff)
downloadgentoo-68452c97485ce39e9639b16816740e7ace19eb3b.tar.gz
gentoo-68452c97485ce39e9639b16816740e7ace19eb3b.tar.bz2
gentoo-68452c97485ce39e9639b16816740e7ace19eb3b.zip
dev-vcs/git-imerge: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild')
-rw-r--r--dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild b/dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..a80c48ab459d
--- /dev/null
+++ b/dev-vcs/git-imerge/git-imerge-0.7.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Incremental merge for git"
+HOMEPAGE="https://github.com/mhagger/git-imerge"
+SRC_URI="https://github.com/mhagger/git-imerge/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-vcs/git"
+DEPEND="dev-python/docutils"
+
+src_compile() {
+ rst2html.py README.rst > README.html || die
+ rst2s5.py \
+ --theme=small-white \
+ --current-slide \
+ doc/presentations/GitMerge-2013/talk.rst doc/presentations/GitMerge-2013/talk.html || die
+}
+
+src_install() {
+ dobin ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/git-imerge.bashcomplete git-imerge
+ dodoc README.rst README.html doc/presentations/GitMerge-2013/talk.html
+}