summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 15:19:56 +0000
committerLars Wendler <polynomial-c@gentoo.org>2021-03-18 10:21:12 +0100
commitc1f1209b423c43587fedc208ba788b662dd8affe (patch)
treed926d3465e9ad21ee377c93450925187f374ba1a /dev-vcs/git/git-9999.ebuild
parentapp-shells/fish: Bump to version 3.2.1 (diff)
downloadgentoo-c1f1209b423c43587fedc208ba788b662dd8affe.tar.gz
gentoo-c1f1209b423c43587fedc208ba788b662dd8affe.tar.bz2
gentoo-c1f1209b423c43587fedc208ba788b662dd8affe.zip
dev-vcs/git: drop USE=pcre-jit from 9999 too
9999 (-r0) tracks stable which is 2.31.x, so that lacks libpcre1 support too. Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild20
1 files changed, 4 insertions, 16 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 564bb8b7b751..ef76ad4668a5 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -51,7 +51,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +pcre-jit perforce +perl +ppcsha1 subversion tk +threads +webdav xinetd cvs test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre perforce +perl +ppcsha1 subversion tk +threads +webdav xinetd cvs test"
# Common to both DEPEND and RDEPEND
DEPEND="
@@ -59,10 +59,7 @@ DEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
sys-libs/zlib
- pcre? (
- pcre-jit? ( dev-libs/libpcre2[jit(+)] )
- !pcre-jit? ( dev-libs/libpcre )
- )
+ pcre? ( dev-libs/libpcre2 )
perl? ( dev-lang/perl:=[-build(-)] )
tk? ( dev-lang/tk:0= )
curl? (
@@ -132,7 +129,6 @@ REQUIRED_USE="
cvs? ( perl )
mediawiki? ( perl )
mediawiki-experimental? ( mediawiki )
- pcre-jit? ( pcre )
perforce? ( ${PYTHON_REQUIRED_USE} )
subversion? ( perl )
webdav? ( curl )
@@ -206,16 +202,8 @@ exportmakeopts() {
sed -i -e '/\/usr\/local/s/BASIC_/#BASIC_/' Makefile || die
if use pcre; then
- if use pcre-jit; then
- myopts+=( USE_LIBPCRE2=YesPlease )
- extlibs+=( -lpcre2-8 )
- else
- myopts+=(
- USE_LIBPCRE1=YesPlease
- NO_LIBPCRE1_JIT=YesPlease
- )
- extlibs+=( -lpcre )
- fi
+ myopts+=( USE_LIBPCRE2=YesPlease )
+ extlibs+=( -lpcre2-8 )
fi
if [[ ${CHOST} == *-solaris* ]]; then
myopts+=(