summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-11-29 11:11:24 +0100
committerFabian Groffen <grobian@gentoo.org>2020-11-29 11:11:41 +0100
commitc0220bd1c32e17136dc9efc956da3c276d4e9d2b (patch)
treea20d0705b85b3ed49a07dc7b0a11fb24b2257aa9 /dev-vcs/git
parentnet-firewall/itval: Remove old (diff)
downloadgentoo-c0220bd1c32e17136dc9efc956da3c276d4e9d2b.tar.gz
gentoo-c0220bd1c32e17136dc9efc956da3c276d4e9d2b.tar.bz2
gentoo-c0220bd1c32e17136dc9efc956da3c276d4e9d2b.zip
dev-vcs/git-2.29.2: don't build osxkeychain module with gcc
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/git-2.29.2.ebuild4
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-vcs/git/git-2.29.2.ebuild b/dev-vcs/git/git-2.29.2.ebuild
index 6e5c5a74a12c..ca7a5942fda8 100644
--- a/dev-vcs/git/git-2.29.2.ebuild
+++ b/dev-vcs/git/git-2.29.2.ebuild
@@ -341,7 +341,7 @@ src_compile() {
|| die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -391,7 +391,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 6e5c5a74a12c..ca7a5942fda8 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -341,7 +341,7 @@ src_compile() {
|| die "emake gitweb (cgi) failed"
fi
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
pushd contrib/credential/osxkeychain &>/dev/null || die
git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
|| die "emake credential-osxkeychain"
@@ -391,7 +391,7 @@ src_compile() {
src_install() {
git_emake install || die "make install failed"
- if [[ ${CHOST} == *-darwin* ]]; then
+ if [[ ${CHOST} == *-darwin* && ! tc-is-gcc ]]; then
dobin contrib/credential/osxkeychain/git-credential-osxkeychain
fi