summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2020-08-20 00:49:07 -0400
committerMike Frysinger <vapier@gentoo.org>2020-08-20 00:49:07 -0400
commit377d5861d13dc5da17af4aed9ba65a54a58cc1a7 (patch)
treef6df77c9bf36993ac3338ea714fb4e4d5df14d33 /dev-vcs/repo
parentdev-perl/ExtUtils-CppGuess: Bump to version 0.210.0 (diff)
downloadgentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.tar.gz
gentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.tar.bz2
gentoo-377d5861d13dc5da17af4aed9ba65a54a58cc1a7.zip
dev-vcs/repo: version bump to 2.8
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'dev-vcs/repo')
-rw-r--r--dev-vcs/repo/Manifest1
-rw-r--r--dev-vcs/repo/repo-2.8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-vcs/repo/Manifest b/dev-vcs/repo/Manifest
index d6b342fbe452..9dc7d7a7269b 100644
--- a/dev-vcs/repo/Manifest
+++ b/dev-vcs/repo/Manifest
@@ -2,3 +2,4 @@ DIST repo-1.26 29829 BLAKE2B c5dc74214d404e6c11189a3d34c9a771ed5689da14e64588b5d
DIST repo-1.27 29945 BLAKE2B 930fa876b8889d64c8d12444f4cd59bebbdf9848d455e114fc9306922d931aa721320db65a07c38f705c39950538a1d5ae5ca66e359d2f2e38061d144ac11cb2 SHA512 a9f651e5fd1da1c74b31aebf32d03cf868183fa529eaf2b079015f9e778a2bb7c1ef49e06564703534c45fa1bd7bc5bd3d91a91477c336e549c1208afa74ace6
DIST repo-2.4 35152 BLAKE2B a069c095524574ee4a7d18cc5cd023f6d71b9ed9b57941180a6ec3ab3c33b2ed18b5dfc7d225a7bc849b7ebfd28bc0e672f7796eb2bb37af0685539c850cfe34 SHA512 46d7b8f699246ad625d5eb714791c29b949c40793343ba56681554040dc1d6a0a5f049e8d96f1e12ca93d77291e95ffd756f76554ebc1062f9cf6fc014aa116a
DIST repo-2.5 38761 BLAKE2B 26d002bb7e5a24dc958bb4e0653c2cc260b2766d81fd55edf9a0373542365ed89a224805293383e2c16d8fc331038b265d3b2aca3a9a637d893f4a9c8221ce76 SHA512 36e515241fd9705c63beaf662309dc2ab6406552ba845fe020c878ac82e7eb7e1cd73924a076cf5fe4800ea70919bb5ad5d2d43566d5b0a559f81a45f9a58fe8
+DIST repo-2.8 39134 BLAKE2B af52a2c06e09de83100cb297d585f89bcbe85d6e9e5c358024a371ee4d47c59992745d1088b164fc670cdd9db7394a5f3521967e3eb80840c53993af8b0172b1 SHA512 6d577fce34eb298035a7b98c24fc21521c8c9efbdf02abc37af8a54552893ecf8cdce2db5efbc5398d7f99226408f6cc9ce2f81c2961d9d5dd21fb0264194431
diff --git a/dev-vcs/repo/repo-2.8.ebuild b/dev-vcs/repo/repo-2.8.ebuild
new file mode 100644
index 000000000000..544acae9a81b
--- /dev/null
+++ b/dev-vcs/repo/repo-2.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The $PV tracks the *repo launcher version*, not the last signed release
+# of the repo project. The launcher only gets a new update when changes are
+# made in it.
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit python-r1
+
+DESCRIPTION="Google tool for managing git, particularly multiple repos"
+HOMEPAGE="https://gerrit.googlesource.com/git-repo"
+SRC_URI="https://storage.googleapis.com/git-repo-downloads/${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !app-admin/radmind
+ !dev-util/repo"
+
+S=${WORKDIR}
+
+src_install() {
+ python_foreach_impl python_newscript "${DISTDIR}/${P}" ${PN}
+}