summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/svn2cl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/svn2cl')
-rw-r--r--dev-vcs/svn2cl/Manifest1
-rw-r--r--dev-vcs/svn2cl/files/0.9-wrapper.patch20
-rw-r--r--dev-vcs/svn2cl/metadata.xml5
-rw-r--r--dev-vcs/svn2cl/svn2cl-0.12.ebuild39
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-vcs/svn2cl/Manifest b/dev-vcs/svn2cl/Manifest
new file mode 100644
index 000000000000..485ddf475425
--- /dev/null
+++ b/dev-vcs/svn2cl/Manifest
@@ -0,0 +1 @@
+DIST svn2cl-0.12.tar.gz 18171 SHA256 abb8976a7862d267eebe98deb1082a9e5a236a63db9dd304794f969ccd777c74 SHA512 c84f0f67b34d615b1732cd03ecbdb6d3bb082677145acf2f32f74518306347eb984d65d4837f2463b369cd7a8a7443d2cfba589c531b46f423870c55b0b48aa2 WHIRLPOOL 9b5b4e7315d6537e0f3a1fbc11f1e7f9e6cff37f4c2d598df853adeab718f7c1f92de81a8c40cd7331544afe1af5fef5b6c60032e7f8818e153455b2e6716883
diff --git a/dev-vcs/svn2cl/files/0.9-wrapper.patch b/dev-vcs/svn2cl/files/0.9-wrapper.patch
new file mode 100644
index 000000000000..478b2a032d2a
--- /dev/null
+++ b/dev-vcs/svn2cl/files/0.9-wrapper.patch
@@ -0,0 +1,20 @@
+--- svn2cl.sh 2006-10-18 23:38:06.000000000 +0200
++++ svn2cl.sh.1 2006-11-12 01:41:05.000000000 +0100
+@@ -234,16 +234,7 @@
+ esac
+ done
+
+-# find the directory that this script resides in
+-prog="$0"
+-while [ -h "$prog" ]
+-do
+- dir=`dirname "$prog"`
+- prog=`ls -ld "$prog" | sed "s/^.*-> \(.*\)/\1/;/^[^/]/s,^,$dir/,"`
+-done
+-dir=`dirname "$prog"`
+-dir=`cd "$dir" && pwd`
+-XSL="$dir/svn2${OUTSTYLE}.xsl"
++XSL="/usr/share/svn2cl/svn2${OUTSTYLE}.xsl"
+
+ # check if the authors file is formatted as a legacy
+ # colon separated file
diff --git a/dev-vcs/svn2cl/metadata.xml b/dev-vcs/svn2cl/metadata.xml
new file mode 100644
index 000000000000..028d1cef3af8
--- /dev/null
+++ b/dev-vcs/svn2cl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-tools</herd>
+</pkgmetadata>
diff --git a/dev-vcs/svn2cl/svn2cl-0.12.ebuild b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
new file mode 100644
index 000000000000..45820434aaba
--- /dev/null
+++ b/dev-vcs/svn2cl/svn2cl-0.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Create a GNU-style ChangeLog from subversion's svn log --xml output"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/svn2cl/"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libxslt
+ dev-vcs/subversion"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # the wrapper script looks for the xsl files in the
+ # same directory as the script.
+ epatch "${FILESDIR}"/0.9-wrapper.patch
+}
+
+src_install() {
+ newbin svn2cl.sh svn2cl || die "failed to install wrapper script"
+ insinto /usr/share/svn2cl
+ doins svn2cl.xsl svn2html.xsl || die
+ dodoc README NEWS TODO ChangeLog authors.xml svn2html.css || die
+ doman svn2cl.1 || die
+}
+
+pkg_postinst() {
+ einfo "You can find samples of svn2html.css and authors.xml in"
+ einfo "/usr/share/doc/${PF}/"
+ einfo "Read man page for details."
+}