summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-01-12 11:43:58 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-01-12 11:44:07 -0800
commita1ce43fc69669cc7a74a1972e59703454a069ddf (patch)
treed92cfd6fd2c078dc36957a8180545076c2825924 /dev-vcs/tig/tig-9999.ebuild
parentdev-vcs/tig: Version bump to 2.5.5. (diff)
downloadgentoo-a1ce43fc69669cc7a74a1972e59703454a069ddf.tar.gz
gentoo-a1ce43fc69669cc7a74a1972e59703454a069ddf.tar.bz2
gentoo-a1ce43fc69669cc7a74a1972e59703454a069ddf.zip
dev-vcs/tig: Sync 9999
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-vcs/tig/tig-9999.ebuild')
-rw-r--r--dev-vcs/tig/tig-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/dev-vcs/tig/tig-9999.ebuild b/dev-vcs/tig/tig-9999.ebuild
index 3ea9666006a2..656ca0a2e20b 100644
--- a/dev-vcs/tig/tig-9999.ebuild
+++ b/dev-vcs/tig/tig-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit bash-completion-r1
@@ -18,14 +18,18 @@ HOMEPAGE="https://jonas.github.io/tig/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="test unicode"
+IUSE="pcre test unicode"
REQUIRED_USE="test? ( unicode )"
DEPEND="
sys-libs/ncurses:=[unicode(+)?]
- sys-libs/readline:0="
-RDEPEND="${DEPEND}
- dev-vcs/git"
+ sys-libs/readline:0=
+ pcre? ( dev-libs/libpcre2:= )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
# encoding/env issues
@@ -37,7 +41,9 @@ src_prepare() {
}
src_configure() {
- econf $(use_with unicode ncursesw)
+ econf \
+ $(use_with pcre) \
+ $(use_with unicode ncursesw)
}
src_compile() {
@@ -47,7 +53,7 @@ src_compile() {
src_test() {
# workaround parallel test failures
- emake -j1 test
+ LC_ALL=en_US.utf8 emake -j1 test
}
src_install() {