summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 15:40:21 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 15:47:26 +0100
commit3a6bd2277d50ef53eb50676b0749d3bce91277dd (patch)
tree4343edd8b5b6664fd29d454524c850c65e79d398 /dev-vcs
parentdev-tex/dot2tex: Clean up old version (diff)
downloadgentoo-3a6bd2277d50ef53eb50676b0749d3bce91277dd.tar.gz
gentoo-3a6bd2277d50ef53eb50676b0749d3bce91277dd.tar.bz2
gentoo-3a6bd2277d50ef53eb50676b0749d3bce91277dd.zip
dev-vcs/mercurial-server: distutils-r1, EAPI=6
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild (renamed from dev-vcs/mercurial-server/mercurial-server-1.2.ebuild)43
-rw-r--r--dev-vcs/mercurial-server/mercurial-server-9999.ebuild43
2 files changed, 44 insertions, 42 deletions
diff --git a/dev-vcs/mercurial-server/mercurial-server-1.2.ebuild b/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild
index 6f78f0191984..9212f8ffff89 100644
--- a/dev-vcs/mercurial-server/mercurial-server-1.2.ebuild
+++ b/dev-vcs/mercurial-server/mercurial-server-1.2-r1.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
+EAPI=6
-inherit distutils eutils user
+# force single impl to avoid python-exec wrapping
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 user
if [[ "${PV}" = "9999" ]]; then
inherit mercurial
@@ -35,45 +38,43 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup hg
enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
+ python-single-r1_pkg_setup
}
-src_prepare() {
+python_prepare_all() {
# remove useless makefile
- rm Makefile
+ rm Makefile || die
# fix installation paths
sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
|| die 'sed setup.py failed.'
- # fix documentation
- if [[ "${PV}" = "1.1" ]]; then
- epatch "${FILESDIR}/${P}_documentation.patch"
- fi
+ distutils-r1_python_prepare_all
}
-src_compile() {
- distutils_src_compile
-
+python_compile_all() {
# build documentation
if use doc; then
xsltproc --nonet -o manual.html \
- /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
- doc/manual.docbook || die "xsltproc failed"
+ /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
+ doc/manual.docbook || die "xsltproc failed"
fi
}
-src_install() {
- distutils_src_install --install-scripts="/usr/share/${PN}"
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/share/${PN}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
# install configuration files
insinto "/etc/${PN}"
- doins -r src/init/conf/*
+ doins -r src/init/conf/.
keepdir /etc/mercurial-server/keys/{root,users}
# install documentation
- if use doc; then
- dohtml manual.html
- fi
+ use doc && dodoc manual.html
# install hg home directory
keepdir "/var/lib/${PN}"
diff --git a/dev-vcs/mercurial-server/mercurial-server-9999.ebuild b/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
index 0c131f4f95e1..c53d6b79af40 100644
--- a/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
+++ b/dev-vcs/mercurial-server/mercurial-server-9999.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-PYTHON_DEPEND="2"
+EAPI=6
-inherit distutils eutils user
+# force single impl to avoid python-exec wrapping
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 user
if [[ "${PV}" = "9999" ]]; then
inherit mercurial
@@ -35,45 +38,43 @@ DEPEND="${RDEPEND}
pkg_setup() {
enewgroup hg
enewuser hg -1 /bin/bash "/var/lib/${PN}" hg
+ python-single-r1_pkg_setup
}
-src_prepare() {
+python_prepare_all() {
# remove useless makefile
- rm Makefile
+ rm Makefile || die
# fix installation paths
sed -i -e "s|'init'|'share/${PN}/init'|" setup.py \
|| die 'sed setup.py failed.'
- # fix documentation
- if [[ "${PV}" = "1.1" ]]; then
- epatch "${FILESDIR}/${P}_documentation.patch"
- fi
+ distutils-r1_python_prepare_all
}
-src_compile() {
- distutils_src_compile
-
+python_compile_all() {
# build documentation
if use doc; then
xsltproc --nonet -o manual.html \
- /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
- doc/manual.docbook || die "xsltproc failed"
+ /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl \
+ doc/manual.docbook || die "xsltproc failed"
fi
}
-src_install() {
- distutils_src_install --install-scripts="/usr/share/${PN}"
+python_install() {
+ distutils-r1_python_install --install-scripts="/usr/share/${PN}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
# install configuration files
insinto "/etc/${PN}"
- doins -r src/init/conf/*
+ doins -r src/init/conf/.
keepdir /etc/mercurial-server/keys/{root,users}
# install documentation
- if use doc; then
- dohtml manual.html
- fi
+ use doc && dodoc manual.html
# install hg home directory
keepdir "/var/lib/${PN}"