summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2021-07-17 11:06:04 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2021-07-17 11:06:04 -0400
commit7624be2cf739bb836403346f4e690cb8f56be65a (patch)
treed660015dd43a9e1d63ba5fb0f9a5efe0404b4aaa /dev-vcs
parentdev-util/pycharm-community: revbump to deliver changes (diff)
downloadgentoo-7624be2cf739bb836403346f4e690cb8f56be65a.tar.gz
gentoo-7624be2cf739bb836403346f4e690cb8f56be65a.tar.bz2
gentoo-7624be2cf739bb836403346f4e690cb8f56be65a.zip
dev-vcs/fossil: Cleanup
Bug: https://bugs.gentoo.org/800638 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/Manifest3
-rw-r--r--dev-vcs/fossil/fossil-2.12.1-r1.ebuild71
-rw-r--r--dev-vcs/fossil/fossil-2.13-r1.ebuild71
-rw-r--r--dev-vcs/fossil/fossil-2.14-r1.ebuild71
4 files changed, 0 insertions, 216 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index 412f2aab1c29..fa3a95902efc 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,4 +1 @@
-DIST fossil-src-2.12.1.tar.gz 6011181 BLAKE2B f9437c4fb20314706bbbec70efbb6a53e2ac7760986baf88ea72505f03877a5d1069d0d2828aa2bfefac96c1358e4c8f824405d61fd24d490442fa8b768711e9 SHA512 08b7fef5a3071e968dedbc645aebf2e873ecf80049b5986d38f851a407b2b8b0c854cfcdfa5ec80eac5bc1b158c5fac3bb4b263d1adb8be470529e67dc6e8cee
-DIST fossil-src-2.13.tar.gz 6121223 BLAKE2B 41bb83b40faf05d38ccbcc13bde858ee31ab0182193631d738a6e287414b2a93bc49bfa5ed0a16aabbc26190c1a3cd993ce9f1706ecd05b214461313b13c1086 SHA512 bd756aaac2f39005b690230c5a4ef4d618a3200a8eb499aa964285050c247edfb0abfa5db5522269e0a5ee2737c71393a523dc2d7e37eae076364185137964f8
-DIST fossil-src-2.14.tar.gz 6207277 BLAKE2B 9a70a49e83e16414150e777289543a984c6b77c4c2ea245ed3187b393a80f6926c80bada31081735d09a9d0febf430587c120e16d60ddbf96d1116c9da6cf008 SHA512 f95291886484c9fb98224c17e07c9c2ada3d79974359234f1cc6a8fce603e45bf980ffe4f43a473d74d190b6975fff66e8d35ca680747385e72981caabfd6b10
DIST fossil-src-2.16.tar.gz 6275775 BLAKE2B 504f828f121385ec73311b340e0abfdba7da6a8571adb390c55c75fea0ef027366fb914c12552e177988bedbb735a3148d87ebdb23ffc2ce4b7bef8ef603692a SHA512 0569640a3b509c592f812a42526eec88ead034ba0ba3de93da62cfb1caa751954ae185eaa3398d411a02ee2a858ecae6cdf4e47199847527f7524fc9798a4b12
diff --git a/dev-vcs/fossil/fossil-2.12.1-r1.ebuild b/dev-vcs/fossil/fossil-2.12.1-r1.ebuild
deleted file mode 100644
index 3d9163f4b783..000000000000
--- a/dev-vcs/fossil/fossil-2.12.1-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Simple, high-reliability, source control management, and more"
-HOMEPAGE="https://www.fossil-scm.org/"
-SRC_URI="https://fossil-scm.org/home/uv/fossil-src-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86"
-IUSE="debug fusefs json miniz system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
-
-REQUIRED_USE="ssl? ( !miniz )"
-
-RDEPEND="
- sys-libs/zlib
- || (
- sys-libs/readline:0
- dev-libs/libedit
- )
- system-sqlite? ( >=dev-db/sqlite-3.33.0:3 )
- ssl? ( dev-libs/openssl:0= )
- tcl? ( dev-lang/tcl:0= )
-"
-
-# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
-DEPEND="${RDEPEND}
- !tcl? (
- || (
- dev-lang/tcl:*
- dev-lang/jimtcl:*
- )
- )
-"
-
-# Tests can't be run from the build directory
-RESTRICT="test"
-
-# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
-PATCHES=( "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch )
-
-src_configure() {
- # this is not an autotools situation so don't make it seem like one
- # --with-tcl: works
- # --without-tcl: dies
- local myconf="--with-openssl=$(usex ssl auto none)"
- use debug && myconf+=' --fossil-debug'
- use json && myconf+=' --json'
- use system-sqlite && myconf+=' --disable-internal-sqlite'
- use static && myconf+=' --static'
- use tcl && myconf+=' --with-tcl=1'
- use fusefs || myconf+=' --disable-fusefs'
-
- local u useflags
- useflags=( miniz tcl-stubs tcl-private-stubs th1-docs th1-hooks )
- for u in ${useflags[@]} ; do
- use ${u} && myconf+=" --with-${u}"
- done
-
- tc-export CC CXX
- CC_FOR_BUILD=${CC} ./configure ${myconf} || die
-}
-
-src_install() {
- dobin fossil
-}
diff --git a/dev-vcs/fossil/fossil-2.13-r1.ebuild b/dev-vcs/fossil/fossil-2.13-r1.ebuild
deleted file mode 100644
index 066d71ae1dfa..000000000000
--- a/dev-vcs/fossil/fossil-2.13-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Simple, high-reliability, source control management, and more"
-HOMEPAGE="https://www.fossil-scm.org/"
-SRC_URI="https://fossil-scm.org/home/uv/fossil-src-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="debug fusefs json miniz system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
-
-REQUIRED_USE="ssl? ( !miniz )"
-
-RDEPEND="
- sys-libs/zlib
- || (
- sys-libs/readline:0
- dev-libs/libedit
- )
- system-sqlite? ( >=dev-db/sqlite-3.34.0:3 )
- ssl? ( dev-libs/openssl:0= )
- tcl? ( dev-lang/tcl:0= )
-"
-
-# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
-DEPEND="${RDEPEND}
- !tcl? (
- || (
- dev-lang/tcl:*
- dev-lang/jimtcl:*
- )
- )
-"
-
-# Tests can't be run from the build directory
-RESTRICT="test"
-
-# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
-PATCHES=( "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch )
-
-src_configure() {
- # this is not an autotools situation so don't make it seem like one
- # --with-tcl: works
- # --without-tcl: dies
- local myconf="--with-openssl=$(usex ssl auto none)"
- use debug && myconf+=' --fossil-debug'
- use json && myconf+=' --json'
- use system-sqlite && myconf+=' --disable-internal-sqlite'
- use static && myconf+=' --static'
- use tcl && myconf+=' --with-tcl=1'
- use fusefs || myconf+=' --disable-fusefs'
-
- local u useflags
- useflags=( miniz tcl-stubs tcl-private-stubs th1-docs th1-hooks )
- for u in ${useflags[@]} ; do
- use ${u} && myconf+=" --with-${u}"
- done
-
- tc-export CC CXX
- CC_FOR_BUILD=${CC} ./configure ${myconf} || die
-}
-
-src_install() {
- dobin fossil
-}
diff --git a/dev-vcs/fossil/fossil-2.14-r1.ebuild b/dev-vcs/fossil/fossil-2.14-r1.ebuild
deleted file mode 100644
index aafaae29c2d2..000000000000
--- a/dev-vcs/fossil/fossil-2.14-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Simple, high-reliability, source control management, and more"
-HOMEPAGE="https://www.fossil-scm.org/"
-SRC_URI="https://fossil-scm.org/home/uv/fossil-src-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="debug fusefs json miniz system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
-
-REQUIRED_USE="ssl? ( !miniz )"
-
-RDEPEND="
- sys-libs/zlib
- || (
- sys-libs/readline:0
- dev-libs/libedit
- )
- system-sqlite? ( >=dev-db/sqlite-3.34.0:3 )
- ssl? ( dev-libs/openssl:0= )
- tcl? ( dev-lang/tcl:0= )
-"
-
-# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
-DEPEND="${RDEPEND}
- !tcl? (
- || (
- dev-lang/tcl:*
- dev-lang/jimtcl:*
- )
- )
-"
-
-# Tests can't be run from the build directory
-RESTRICT="test"
-
-# fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
-PATCHES=( "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch )
-
-src_configure() {
- # this is not an autotools situation so don't make it seem like one
- # --with-tcl: works
- # --without-tcl: dies
- local myconf="--with-openssl=$(usex ssl auto none)"
- use debug && myconf+=' --fossil-debug'
- use json && myconf+=' --json'
- use system-sqlite && myconf+=' --disable-internal-sqlite'
- use static && myconf+=' --static'
- use tcl && myconf+=' --with-tcl=1'
- use fusefs || myconf+=' --disable-fusefs'
-
- local u useflags
- useflags=( miniz tcl-stubs tcl-private-stubs th1-docs th1-hooks )
- for u in ${useflags[@]} ; do
- use ${u} && myconf+=" --with-${u}"
- done
-
- tc-export CC CXX
- CC_FOR_BUILD=${CC} ./configure ${myconf} || die
-}
-
-src_install() {
- dobin fossil
-}