summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-11-18 10:12:06 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-11-18 10:14:03 +0300
commit566f4d032300984b14e1ee3325d01d3a2ec2cdde (patch)
tree9fc3701355728d79e63bb814f755bae1fc11fd42 /eclass/leechcraft.eclass
parentdev-python/pysnmp: Version bump. (diff)
downloadgentoo-566f4d032300984b14e1ee3325d01d3a2ec2cdde.tar.gz
gentoo-566f4d032300984b14e1ee3325d01d3a2ec2cdde.tar.bz2
gentoo-566f4d032300984b14e1ee3325d01d3a2ec2cdde.zip
leechcraft.eclass: correct EAPI support sentence in comments, reorganize compiler version check
Diffstat (limited to 'eclass/leechcraft.eclass')
-rw-r--r--eclass/leechcraft.eclass8
1 files changed, 3 insertions, 5 deletions
diff --git a/eclass/leechcraft.eclass b/eclass/leechcraft.eclass
index b9fc73b4350..ffc647adea2 100644
--- a/eclass/leechcraft.eclass
+++ b/eclass/leechcraft.eclass
@@ -19,7 +19,7 @@
#
# Thanks for original eclass to Andrian Nord <NightNord@niifaq.ru>.
#
-# Only EAPI >1 supported
+# Only EAPI >3 supported
case ${EAPI:-0} in
4|5) ;;
@@ -68,15 +68,13 @@ EXPORT_FUNCTIONS "pkg_pretend"
leechcraft_pkg_pretend() {
debug-print-function ${FUNCNAME} "$@"
- # 0.5.85 and later requires at least gcc 4.6
if [[ ${MERGE_TYPE} != binary ]]; then
+ # All in-tree versions require at least gcc 4.6
[[ $(gcc-major-version) -lt 4 ]] || \
( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
&& die "Sorry, but gcc 4.6 or higher is required."
- fi
- if version_is_at_least 0.6.66 || ( [[ ${PN} == lc-monocle ]] && version_is_at_least 0.6.65 ); then
# 0.6.65 monocle and all later plugins require at least gcc 4.8
- if [[ ${MERGE_TYPE} != binary ]]; then
+ if version_is_at_least 0.6.66 || ( [[ ${PN} == lc-monocle ]] && version_is_at_least 0.6.65 ); then
[[ $(gcc-major-version) -lt 4 ]] || \
( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 8 ]] ) \
&& die "Sorry, but gcc 4.8 or higher is required."