summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-08-13 10:30:28 +0100
committerMarek Szuba <marecki@gentoo.org>2021-08-13 11:02:05 +0100
commit6b43b6820aacebbc4c79fef372a2776ea69799be (patch)
treed53e72bc6aff3599ea949f58d5047504c72e5bc0 /eclass/lua-utils.eclass
parentkde-misc/kdeconnect: Add missing DEPEND (diff)
downloadgentoo-6b43b6820aacebbc4c79fef372a2776ea69799be.tar.gz
gentoo-6b43b6820aacebbc4c79fef372a2776ea69799be.tar.bz2
gentoo-6b43b6820aacebbc4c79fef372a2776ea69799be.zip
lua-utils.eclass: lua5-2 is now a historic implementation
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'eclass/lua-utils.eclass')
-rw-r--r--eclass/lua-utils.eclass5
1 files changed, 3 insertions, 2 deletions
diff --git a/eclass/lua-utils.eclass b/eclass/lua-utils.eclass
index 12067928002..954f776cda2 100644
--- a/eclass/lua-utils.eclass
+++ b/eclass/lua-utils.eclass
@@ -34,7 +34,6 @@ inherit toolchain-funcs
_LUA_ALL_IMPLS=(
luajit
lua5-1
- lua5-2
lua5-3
lua5-4
)
@@ -44,7 +43,9 @@ readonly _LUA_ALL_IMPLS
# @INTERNAL
# @DESCRIPTION:
# All historical Lua implementations that are no longer supported.
-_LUA_HISTORICAL_IMPLS=()
+_LUA_HISTORICAL_IMPLS=(
+ lua5-2
+)
readonly _LUA_HISTORICAL_IMPLS
# @FUNCTION: _lua_set_impls