summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-14 23:33:11 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-08-15 18:37:18 +0200
commit843c1d8de0b2eb34a91760c2c9cbffab7dafe5b7 (patch)
tree3ec215d7626cd3ecb359340fe2b4d20d0fe48f95 /eclass/perl-module.eclass
parentnet-print/hplip: Remove old hplip-3.18.12.ebuild, hplip-3.19.5 (diff)
downloadgentoo-843c1d8de0b2eb34a91760c2c9cbffab7dafe5b7.tar.gz
gentoo-843c1d8de0b2eb34a91760c2c9cbffab7dafe5b7.tar.bz2
gentoo-843c1d8de0b2eb34a91760c2c9cbffab7dafe5b7.zip
perl-module.eclass: Also populate BDEPEND in EAPI=7
In addition, no slot op in DEPEND. Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'eclass/perl-module.eclass')
-rw-r--r--eclass/perl-module.eclass31
1 files changed, 29 insertions, 2 deletions
diff --git a/eclass/perl-module.eclass b/eclass/perl-module.eclass
index 81f79992d766..e1fb97df3260 100644
--- a/eclass/perl-module.eclass
+++ b/eclass/perl-module.eclass
@@ -72,13 +72,13 @@ case ${EAPI:-0} in
;;
esac
;;
- 6|7)
+ 6)
[[ ${CATEGORY} == perl-core ]] && \
PERL_EXPF+=" pkg_postinst pkg_postrm"
case "${GENTOO_DEPEND_ON_PERL:-yes}" in
yes)
- DEPEND="dev-lang/perl:="
+ DEPEND="dev-lang/perl"
RDEPEND="dev-lang/perl:="
;;
noslotop)
@@ -99,6 +99,33 @@ case ${EAPI:-0} in
EXPORT_FUNCTIONS ${PERL_EXPF}
;;
+ 7)
+ [[ ${CATEGORY} == perl-core ]] && \
+ PERL_EXPF+=" pkg_postinst pkg_postrm"
+
+ case "${GENTOO_DEPEND_ON_PERL:-yes}" in
+ yes)
+ DEPEND="dev-lang/perl"
+ BDEPEND="dev-lang/perl"
+ RDEPEND="dev-lang/perl:="
+ ;;
+ noslotop)
+ DEPEND="dev-lang/perl"
+ BDEPEND="dev-lang/perl"
+ RDEPEND="dev-lang/perl"
+ ;;
+ esac
+
+ if [[ "${GENTOO_DEPEND_ON_PERL_SUBSLOT:-yes}" != "yes" ]]; then
+ die "GENTOO_DEPEND_ON_PERL_SUBSLOT=no is banned in EAPI=6 and later."
+ fi
+
+ if [[ "${PERL_EXPORT_PHASE_FUNCTIONS}" ]]; then
+ die "PERL_EXPORT_PHASE_FUNCTIONS is banned in EAPI=6 and later."
+ fi
+
+ EXPORT_FUNCTIONS ${PERL_EXPF}
+ ;;
*)
die "EAPI=${EAPI:-0} is not supported by perl-module.eclass"
;;