summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-03-01 09:36:50 +0100
committerMichał Górny <mgorny@gentoo.org>2017-03-08 08:35:46 +0100
commit30122ca588e0b7e86bb149aeef439b806c6ab0e0 (patch)
tree79ac332261369463230f99db6a96a54143309d28 /eclass/python-r1.eclass
parentpython-any-r1.eclass: Add integrity check for globals (diff)
downloadgentoo-30122ca588e0b7e86bb149aeef439b806c6ab0e0.tar.gz
gentoo-30122ca588e0b7e86bb149aeef439b806c6ab0e0.tar.bz2
gentoo-30122ca588e0b7e86bb149aeef439b806c6ab0e0.zip
python-r1.eclass: Remove stale EAPI=4 branch in globals
Diffstat (limited to 'eclass/python-r1.eclass')
-rw-r--r--eclass/python-r1.eclass8
1 files changed, 2 insertions, 6 deletions
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index 4d27881cd5c..18f11fd597d 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: python-r1.eclass
@@ -195,14 +195,10 @@ _python_set_globals() {
# but no point in making this overcomplex, BDEP doesn't hurt anyone
# 2) python-exec should be built with all targets forced anyway
# but if new targets were added, we may need to force a rebuild
- # 3) use whichever python-exec slot installed in EAPI 5. For EAPI 4,
- # just fix :2 since := deps are not supported.
if [[ ${_PYTHON_WANT_PYTHON_EXEC2} == 0 ]]; then
die "python-exec:0 is no longer supported, please fix your ebuild to work with python-exec:2"
- elif [[ ${EAPI} != 4 ]]; then
- PYTHON_DEPS+=">=dev-lang/python-exec-2:=[${PYTHON_USEDEP}]"
else
- PYTHON_DEPS+="dev-lang/python-exec:2[${PYTHON_USEDEP}]"
+ PYTHON_DEPS+=">=dev-lang/python-exec-2:=[${PYTHON_USEDEP}]"
fi
readonly PYTHON_DEPS PYTHON_REQUIRED_USE PYTHON_USEDEP
}