summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-11 01:22:27 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-11 09:49:59 -0400
commit519631a417eb4f8d2ffd4c850a08e82b08ba6696 (patch)
tree3678a7f76e2f5060fdb87f1b3ba792dac11fac53 /eclass/toolchain.eclass
parentprofiles: mask kde-apps/khelpcenter-5.6.4 due to a suspect tarball (diff)
downloadgentoo-519631a417eb4f8d2ffd4c850a08e82b08ba6696.tar.gz
gentoo-519631a417eb4f8d2ffd4c850a08e82b08ba6696.tar.bz2
gentoo-519631a417eb4f8d2ffd4c850a08e82b08ba6696.zip
sys-devel/gcc: add USE=mpx support for Intel MPX #578396
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 992074084d2..08813a9e355 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -153,7 +153,7 @@ if [[ ${PN} != "kgcc64" && ${PN} != gcc-* ]] ; then
# the older versions, we don't want to bother supporting it. #448024
tc_version_is_at_least 4.8 && IUSE+=" graphite" IUSE_DEF+=( sanitize )
tc_version_is_at_least 4.9 && IUSE+=" cilk +vtv"
- tc_version_is_at_least 5.0 && IUSE+=" jit"
+ tc_version_is_at_least 5.0 && IUSE+=" jit mpx"
tc_version_is_at_least 6.0 && IUSE+=" pie +ssp"
fi
@@ -1165,6 +1165,10 @@ toolchain_src_configure() {
confgcc+=( $(use_enable cilk libcilkrts) )
fi
+ if in_iuse mpx ; then
+ confgcc+=( $(use_enable mpx libmpx) )
+ fi
+
if in_iuse vtv ; then
confgcc+=(
$(use_enable vtv vtable-verify)