summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-30 23:45:29 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-31 00:30:22 -0500
commite824d4550088fd20c587d4d4ce93684f57f70645 (patch)
treec5d00e2a4d607ed558203ee1e0bd22011f2aafdd /eclass/toolchain.eclass
parentsys-devel/gcc: move old 4.8 and 4.9 versions to toolchain overlay (diff)
downloadgentoo-e824d4550088fd20c587d4d4ce93684f57f70645.tar.gz
gentoo-e824d4550088fd20c587d4d4ce93684f57f70645.tar.bz2
gentoo-e824d4550088fd20c587d4d4ce93684f57f70645.zip
toolchain.eclass: enable multislot for gcc-4.7 versions
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index b18d41816eb..6d704fb8f2a 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -159,7 +159,7 @@ fi
IUSE+=" ${IUSE_DEF[*]/#/+}"
# Support upgrade paths here or people get pissed
-if ! tc_version_is_at_least 4.7 || is_crosscompile || use multislot || [[ ${GCC_PV} == *_alpha* ]] ; then
+if ! tc_version_is_at_least 4.8 || is_crosscompile || use multislot || [[ ${GCC_PV} == *_alpha* ]] ; then
SLOT="${GCC_CONFIG_VER}"
elif ! tc_version_is_at_least 5.0 ; then
SLOT="${GCC_BRANCH_VER}"