summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-05-20 12:49:35 +0300
committerMart Raudsepp <leio@gentoo.org>2017-05-20 12:49:35 +0300
commit616c42803a9b773910099484606043e8d9ede3a7 (patch)
tree3e7ce0febefe8528adf4080439076ff9ae9bd13f /eclass/vala.eclass
parentgnome-extra/gnome-builder: remove old (diff)
downloadgentoo-616c42803a9b773910099484606043e8d9ede3a7.tar.gz
gentoo-616c42803a9b773910099484606043e8d9ede3a7.tar.bz2
gentoo-616c42803a9b773910099484606043e8d9ede3a7.zip
vala.eclass: Raise minimal vala version
Diffstat (limited to 'eclass/vala.eclass')
-rw-r--r--eclass/vala.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/vala.eclass b/eclass/vala.eclass
index 1f1df82a15e..37011ab34ec 100644
--- a/eclass/vala.eclass
+++ b/eclass/vala.eclass
@@ -25,8 +25,8 @@ esac
# @ECLASS-VARIABLE: VALA_MIN_API_VERSION
# @DESCRIPTION:
-# Minimum vala API version (e.g. 0.26).
-VALA_MIN_API_VERSION=${VALA_MIN_API_VERSION:-0.26}
+# Minimum vala API version (e.g. 0.32).
+VALA_MIN_API_VERSION=${VALA_MIN_API_VERSION:-0.32}
# @ECLASS-VARIABLE: VALA_MAX_API_VERSION
# @DESCRIPTION:
@@ -49,7 +49,7 @@ vala_api_versions() {
local minimal_supported_minor_version minor_version
# Dependency atoms are not generated for Vala versions older than 0.${minimal_supported_minor_version}.
- minimal_supported_minor_version="26"
+ minimal_supported_minor_version="32"
for ((minor_version = ${VALA_MAX_API_VERSION#*.}; minor_version >= ${VALA_MIN_API_VERSION#*.}; minor_version = minor_version - 2)); do
if ((minor_version >= minimal_supported_minor_version)); then