summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 19:30:08 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 21:24:30 +0100
commit99e5d2b86987087568df9d53d669da3c922dc8c2 (patch)
tree9a3f3d22b58e8b730a2f764170ff09e9ee93a8a7 /eclass
parentapp-text/ghostscript-gpl: Re-enable parallel build and give it some testing... (diff)
downloadgentoo-99e5d2b86987087568df9d53d669da3c922dc8c2.tar.gz
gentoo-99e5d2b86987087568df9d53d669da3c922dc8c2.tar.bz2
gentoo-99e5d2b86987087568df9d53d669da3c922dc8c2.zip
python-r1.eclass: Wipe obsolete EAPI=4 exceptions
Diffstat (limited to 'eclass')
-rw-r--r--eclass/python-r1.eclass16
1 files changed, 1 insertions, 15 deletions
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index a117a5a82ff..702fa288096 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -30,23 +30,9 @@
# https://wiki.gentoo.org/wiki/Project:Python/python-r1
case "${EAPI:-0}" in
- 0|1|2|3)
+ 0|1|2|3|4)
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 4)
- # EAPI=4 is only allowed on legacy packages
- if [[ ${CATEGORY}/${P} == dev-python/pyelftools-0.2[123] ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/file-5.22 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/i2c-tools-3.1.1 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-libs/cracklib-2.9.[12] ]]; then
- :
- else
- die "Unsupported EAPI=${EAPI:-4} (too old, allowed only on restricted set of packages) for ${ECLASS}"
- fi
- ;;
5|6)
# EAPI=5 is required for sane USE_EXPAND dependencies
;;