summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-17 21:00:42 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-17 21:24:40 +0100
commita32e57790ec7e8ece47f305392b85e3ef3d2a436 (patch)
treeb353f9cd53c21cdf5be8cad0db87555533e562c4 /eclass
parentsys-apps/paludis: Clean old version up (diff)
downloadgentoo-a32e57790ec7e8ece47f305392b85e3ef3d2a436.tar.gz
gentoo-a32e57790ec7e8ece47f305392b85e3ef3d2a436.tar.bz2
gentoo-a32e57790ec7e8ece47f305392b85e3ef3d2a436.zip
python-single-r1.eclass: Remove EAPI=4 exceptions
Diffstat (limited to 'eclass')
-rw-r--r--eclass/python-single-r1.eclass22
1 files changed, 1 insertions, 21 deletions
diff --git a/eclass/python-single-r1.eclass b/eclass/python-single-r1.eclass
index 16102816f14..db08cab1e85 100644
--- a/eclass/python-single-r1.eclass
+++ b/eclass/python-single-r1.eclass
@@ -32,29 +32,9 @@
# https://wiki.gentoo.org/wiki/Project:Python/python-single-r1
case "${EAPI:-0}" in
- 0|1|2|3)
+ 0|1|2|3|4)
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 4)
- # EAPI=4 is only allowed on legacy packages
- if [[ ${CATEGORY}/${P} == app-arch/threadzip-1.2 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == media-libs/lv2-1.8.0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == media-libs/lv2-1.10.0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/paludis-1* ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/paludis-2.[02].0 ]]; then
- :
- elif [[ ${CATEGORY}/${P} == sys-apps/util-linux-2.2[456]* ]]; then
- :
- elif [[ ${CATEGORY}/${P} == */gdb-7.[78]* ]]; then
- :
- else
- die "Unsupported EAPI=${EAPI:-4} (too old, allowed only on restricted set of packages) for ${ECLASS}"
- fi
- ;;
5|6)
# EAPI=5 is required for sane USE_EXPAND dependencies
;;