summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/beathazardultra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/beathazardultra')
-rw-r--r--games-action/beathazardultra/Manifest1
-rw-r--r--games-action/beathazardultra/beathazardultra-20130308.ebuild83
-rw-r--r--games-action/beathazardultra/metadata.xml10
3 files changed, 94 insertions, 0 deletions
diff --git a/games-action/beathazardultra/Manifest b/games-action/beathazardultra/Manifest
new file mode 100644
index 000000000000..59ff987f1f80
--- /dev/null
+++ b/games-action/beathazardultra/Manifest
@@ -0,0 +1 @@
+DIST beathazard-installer_03-08-13 183569201 SHA256 ba5d67d820b3367b7080cd73f433d13964285904a55d5be6578bbe9966963faa SHA512 273f550034473d43ac4ceb41018b540f6518393606249de490642a4e6f0dfb5f0b860d3a633db0f90f3b9fce1dc156cf4bd80d383f7e6eae91a5e7bd9e9427d4 WHIRLPOOL 91032365fce84eff65361397935f9e36eae8740f5ae947c976e2e30e76396e55423d8d959ce4476688d8c77d92b57c951c581023e675b1c59f8c286172ff5ec3
diff --git a/games-action/beathazardultra/beathazardultra-20130308.ebuild b/games-action/beathazardultra/beathazardultra-20130308.ebuild
new file mode 100644
index 000000000000..c3fd13593291
--- /dev/null
+++ b/games-action/beathazardultra/beathazardultra-20130308.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: unbundle allegro[gtk...] (no multilib on amd64 and 5.0.9 soname)
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Intense music-driven arcade shooter powered by your music"
+HOMEPAGE="http://www.coldbeamgames.com/"
+SRC_URI="beathazard-installer_03-08-13"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/BeatHazard_Linux2
+ ${MYGAMEDIR#/}/hge_lib/*"
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ virtual/opengl
+ amd64? (
+ !bundled-libs? (
+ >=media-libs/libpng-1.2.51:1.2[abi_x86_32(-)]
+ >=virtual/jpeg-0-r2[abi_x86_32(-)]
+ )
+ >=x11-libs/gtk+-2.24.23:2[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXinerama-1.1.3[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ )
+ x86? (
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ !bundled-libs? (
+ media-libs/libpng:1.2
+ virtual/jpeg
+ )
+ )"
+
+S=${WORKDIR}/data
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ if ! use bundled-libs ; then
+ einfo "Removing bundled libs..."
+ rm -v all/hge_lib/libjpeg.so* all/hge_lib/libpng12.so* || die
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ doins -r all/*
+
+ dodoc Linux.README
+
+ newicon SmileLogo.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./BeatHazard_Linux2" "${MYGAMEDIR}" "${MYGAMEDIR}/hge_lib"
+
+ fperms +x "${MYGAMEDIR}"/BeatHazard_Linux2
+ prepgamesdirs
+}
diff --git a/games-action/beathazardultra/metadata.xml b/games-action/beathazardultra/metadata.xml
new file mode 100644
index 000000000000..fcab3b2f70ac
--- /dev/null
+++ b/games-action/beathazardultra/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>