summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-06 12:54:48 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-06 12:55:05 -0500
commit2ee2a108fa08b1ee1722fbd328f38c13f23fee2b (patch)
tree3ae979d74a99cf1679bf190c66a4269d34902529 /games-action/chickens
parentsys-apps/openrc: 0.21.2 version bump (diff)
downloadgentoo-2ee2a108fa08b1ee1722fbd328f38c13f23fee2b.tar.gz
gentoo-2ee2a108fa08b1ee1722fbd328f38c13f23fee2b.tar.bz2
gentoo-2ee2a108fa08b1ee1722fbd328f38c13f23fee2b.zip
games-action/chickens: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-action/chickens')
-rw-r--r--games-action/chickens/chickens-0.2.4-r1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/games-action/chickens/chickens-0.2.4-r1.ebuild b/games-action/chickens/chickens-0.2.4-r1.ebuild
new file mode 100644
index 000000000000..bf90160c2071
--- /dev/null
+++ b/games-action/chickens/chickens-0.2.4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils user
+
+MY_P="ChickensForLinux-Linux-${PV}"
+DESCRIPTION="Target chickens with rockets and shotguns. Funny"
+HOMEPAGE="http://www.chickensforlinux.com/"
+SRC_URI="http://www.chickensforlinux.com/${MY_P}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:HighScores:/var/games//${PN}/HighScores:" \
+ -e "s:....\(.\)\(_\)\(.*.4x0\)\(.\):M\4\2\x42\x6Fn\1s\2:" \
+ highscore.cpp HighScores || die
+ sed -i \
+ -e "s:options.cfg:/etc/${PN}/options.cfg:" \
+ -e "s:\"sound/:\"/usr/share/${PN}/sound/:" \
+ -e "s:\"dat/:\"/usr/share/${PN}/dat/:" \
+ main.cpp README || die
+ sed -i \
+ -e '/^CPPFLAGS/d' \
+ -e 's:g++:\\$(CXX) \\$(CXXFLAGS) \\$(LDFLAGS):' \
+ configure || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r dat sound
+ dodoc AUTHOR README
+ insinto /var/games/${PN}
+ doins HighScores
+ insinto /etc/${PN}
+ doins options.cfg
+ make_desktop_entry ${PN} Chickens
+
+ fowners root:gamestat /usr/bin/${PN} /var/games/${PN}/HighScores
+ fperms 2755 /usr/bin/${PN}
+ fperms 660 /var/games/${PN}/HighScores
+}