summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-06-21 18:11:11 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-06-23 20:48:19 -0400
commit6723f7ac4d1431c7cebc595fbac079ea54857fe3 (patch)
tree8d3039c9283b809a81fae5a552a097f5a1bfee32 /games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
parentx11-drivers/xf86-input-libinput: Version bump to 1.1.0 (diff)
downloadgentoo-6723f7ac4d1431c7cebc595fbac079ea54857fe3.tar.gz
gentoo-6723f7ac4d1431c7cebc595fbac079ea54857fe3.tar.bz2
gentoo-6723f7ac4d1431c7cebc595fbac079ea54857fe3.zip
games-action/moon-buggy: EAPI7, add missing eclass, fix LICENSE
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild b/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
index 0347e5bfa292..9430a6baa4a0 100644
--- a/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
+++ b/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
@@ -1,41 +1,42 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools
+EAPI=7
-DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Simple console game, where you drive a car across the moon's surface"
HOMEPAGE="https://www.seehuhn.de/pages/moon-buggy.html"
SRC_URI="https://m.seehuhn.de/programs/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
RDEPEND="acct-group/gamestat
sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
sed -i \
-e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
Makefile.am || die
- rm -f missing
+ rm missing || die
eautoreconf
}
src_configure() {
econf \
- --sharedstatedir="/var/games" \
+ --sharedstatedir="${EPREFIX}/var/games" \
--with-curses-libs="$($(tc-getPKG_CONFIG) ncurses --libs)"
}
src_install() {
default
- touch "${D}/var/games/${PN}/mbscore"
+
+ touch "${ED}/var/games/${PN}/mbscore" || die
fowners root:gamestat /usr/bin/${PN} /var/games/${PN} /var/games/${PN}/mbscore
fperms 2755 /usr/bin/${PN}
fperms 664 /var/games/${PN}/mbscore