summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:03:33 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:03:33 +0200
commitc6d6c2fca64f58fdd4af810a6816ac13973f95e7 (patch)
tree7a40d878791dec526b3d0bd128230f65c81e6cb8 /games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
parentapp-misc/abook: cleanup patches (diff)
downloadgentoo-c6d6c2fca64f58fdd4af810a6816ac13973f95e7.tar.gz
gentoo-c6d6c2fca64f58fdd4af810a6816ac13973f95e7.tar.bz2
gentoo-c6d6c2fca64f58fdd4af810a6816ac13973f95e7.zip
games-action/moon-buggy: add pkgconfig or pkgconfig-referenced libs deps
Add dependencies for either virtual/pkgconfig, move it into BDEPEND where applicable, or add dependencies for libraries we're trying to find with pkgconfig. Package-Manager: Portage-3.0.18-prefix, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild')
-rw-r--r--games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild b/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
new file mode 100644
index 000000000000..0347e5bfa292
--- /dev/null
+++ b/games-action/moon-buggy/moon-buggy-1.0.51-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A simple console game, where you drive a car across the moon's surface"
+HOMEPAGE="https://www.seehuhn.de/pages/moon-buggy.html"
+SRC_URI="https://m.seehuhn.de/programs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="acct-group/gamestat
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/$(DESTDIR)$(bindir)\/moon-buggy -c/d' \
+ Makefile.am || die
+ rm -f missing
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sharedstatedir="/var/games" \
+ --with-curses-libs="$($(tc-getPKG_CONFIG) ncurses --libs)"
+}
+
+src_install() {
+ default
+ touch "${D}/var/games/${PN}/mbscore"
+ fowners root:gamestat /usr/bin/${PN} /var/games/${PN} /var/games/${PN}/mbscore
+ fperms 2755 /usr/bin/${PN}
+ fperms 664 /var/games/${PN}/mbscore
+}