summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-21 14:12:57 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-21 14:13:22 +0100
commit1b6a0e8a80fd8209260f40423be424d7105e8386 (patch)
tree04382a4da4822e746a499c251851f96d2c4601db /games-action
parentdev-ml/ounit2: remove seq reference from dune build file (diff)
downloadgentoo-1b6a0e8a80fd8209260f40423be424d7105e8386.tar.gz
gentoo-1b6a0e8a80fd8209260f40423be424d7105e8386.tar.bz2
gentoo-1b6a0e8a80fd8209260f40423be424d7105e8386.zip
games-action/bzflag: add 2.4.26
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bzflag/Manifest1
-rw-r--r--games-action/bzflag/bzflag-2.4.26.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/games-action/bzflag/Manifest b/games-action/bzflag/Manifest
index fee7f3fa030d..268b6e3dcba3 100644
--- a/games-action/bzflag/Manifest
+++ b/games-action/bzflag/Manifest
@@ -1 +1,2 @@
DIST bzflag-2.4.24.tar.bz2 14094506 BLAKE2B 4b14f00ce071d69b75091d0492ce26862e1f01356c61048ba46381f60f091b5dbf144d979e1f07bc87f4bd1159df3fc48c739fa370c92b7cf630308c8478ce24 SHA512 2e6c620e39e65058397515f309b58b0338ee972a63b241546f9947889a43b6274ce313fe5551517d1a099963d0ce877c67e29dfb70d424626926e77b9562c3f7
+DIST bzflag-2.4.26.tar.bz2 14107130 BLAKE2B f7fe50910f49f82c7316d19f7b5dba2de26cbe2b928c29158b725be6424d5a55423e2d390c8c0d96cc40ff90191c6d1ab0d378014381ef44f6fcd534c06fc9a9 SHA512 1ca039d840440098ea788009ad94fccec20710f621967843b5f95dc4ee054cb1d5d9b94326687008cf7a11020889225ffe9001aac1c7c4339f6761961f422a78
diff --git a/games-action/bzflag/bzflag-2.4.26.ebuild b/games-action/bzflag/bzflag-2.4.26.ebuild
new file mode 100644
index 000000000000..704daa557b95
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.26.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="https://www.bzflag.org/"
+SRC_URI="https://download.bzflag.org/bzflag/source/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated upnp"
+
+RDEPEND="
+ net-dns/c-ares
+ >=net-misc/curl-7.15.0
+ sys-libs/ncurses:0
+ sys-libs/zlib
+ !dedicated? (
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/glew:=
+ virtual/glu
+ virtual/opengl )
+ upnp? ( net-libs/miniupnpc )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.12-configure.patch
+ "${FILESDIR}"/${PN}-2.4.12-tinfo.patch
+ "${FILESDIR}"/${PN}-2.4.12-sdl2-cppflags.patch
+)
+
+DOCS=( AUTHORS ChangeLog DEVINFO PORTING README README.Linux )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable upnp UPnP)
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ )
+
+ if use dedicated ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf+=( --disable-client --without-SDL )
+ else
+ myconf=( --with-SDL=2 )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use dedicated ; then
+ newicon data/bzflag-48x48.png ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}