summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-19 14:00:46 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-19 14:34:01 +0100
commit2d455be6ff15a46617eeaa2dec52d1f1b6e05f75 (patch)
tree7334f72f51ae1821440d9a13afa3e4bcaacfd371 /games-action
parentx11-terms/aterm: stable 1.0.1-r3 for ppc, bug #638072 (diff)
downloadgentoo-2d455be6ff15a46617eeaa2dec52d1f1b6e05f75.tar.gz
gentoo-2d455be6ff15a46617eeaa2dec52d1f1b6e05f75.tar.bz2
gentoo-2d455be6ff15a46617eeaa2dec52d1f1b6e05f75.zip
games-action/0verkill: Minor touchups
Closes: https://bugs.gentoo.org/626284 Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'games-action')
-rw-r--r--games-action/0verkill/0verkill-0.16-r4.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/games-action/0verkill/0verkill-0.16-r4.ebuild b/games-action/0verkill/0verkill-0.16-r4.ebuild
index b512d03cdb80..478fcc1bbda7 100644
--- a/games-action/0verkill/0verkill-0.16-r4.ebuild
+++ b/games-action/0verkill/0verkill-0.16-r4.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils
-DESCRIPTION="a bloody 2D action deathmatch-like game in ASCII-ART"
-HOMEPAGE="http://artax.karlin.mff.cuni.cz/~brain/0verkill/"
+inherit autotools
+
+DESCRIPTION="A bloody 2D action deathmatch-like game in ASCII-ART"
+HOMEPAGE="http://freecode.com/projects/0verkill"
SRC_URI="http://artax.karlin.mff.cuni.cz/~brain/0verkill/release/${P}.tgz"
LICENSE="GPL-2"
@@ -34,6 +35,8 @@ src_prepare() {
-e "s:@CFLAGS@ -O3 :@CFLAGS@ :" Makefile.in || die
sed -i \
-e "/gettimeofday/s/getopt/getopt calloc/" configure.in || die
+
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -42,8 +45,8 @@ src_configure() {
}
src_install() {
- local x
dobin 0verkill
+ local x
for x in avi bot editor server test_server ; do
newbin ${x} 0verkill-${x}
done
@@ -54,9 +57,9 @@ src_install() {
done
fi
- insinto "/usr/share/${PN}"
+ insinto /usr/share/${PN}
doins -r data grx
- rm doc/README.OS2 doc/Readme\ Win32.txt doc/COPYING
- dodoc -r doc/
+ rm doc/{README.OS2,"Readme Win32.txt",COPYING} || die
+ dodoc -r doc/.
}