summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-14 19:40:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-14 22:40:36 -0400
commit8452ad75bf37de53704fc1bdf435e48b87bef45f (patch)
tree53c6c629ce03af033c58e07342cba3cf798851be /games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild
parentgames-action/geki3-KXL: EAPI6->8, fix clang/fonts, cleanup patches (diff)
downloadgentoo-8452ad75bf37de53704fc1bdf435e48b87bef45f.tar.gz
gentoo-8452ad75bf37de53704fc1bdf435e48b87bef45f.tar.bz2
gentoo-8452ad75bf37de53704fc1bdf435e48b87bef45f.zip
games-arcade/grande-KXL: EAPI6->8, use gamestat, add font dep
Also fix .desktop icon, bmp is not valid for XDG icons. Closes: https://bugs.gentoo.org/682606 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild')
-rw-r--r--games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild b/games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild
new file mode 100644
index 000000000000..f93c692bec64
--- /dev/null
+++ b/games-arcade/grande-KXL/grande-KXL-0.6-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="ZANAC type game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/gamestat
+ dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi
+ media-fonts/font-bitstream-100dpi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-paths.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-highscore-path="${EPREFIX}/var/games"
+}
+
+src_install() {
+ dodir /var/games
+ default
+
+ fowners :gamestat /var/games/grande.scores /usr/bin/grande
+ fperms g+s /usr/bin/grande
+ fperms 660 /var/games/grande.scores
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry grande Grande
+}