summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-20 20:33:07 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-20 20:35:50 -0500
commit05da0fe97b122dc34457bfb3fa4ca6cd24d3fe45 (patch)
tree9ef139f5b0dcba90620774c5e0040fb0d2108ef3 /games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild
parentgames-action/battalion: fix build w/ upcoming clang16 (diff)
downloadgentoo-05da0fe97b122dc34457bfb3fa4ca6cd24d3fe45.tar.gz
gentoo-05da0fe97b122dc34457bfb3fa4ca6cd24d3fe45.tar.bz2
gentoo-05da0fe97b122dc34457bfb3fa4ca6cd24d3fe45.zip
games-arcade/grande-KXL: fix build w/ upcoming clang16
Closes: https://bugs.gentoo.org/874990 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild')
-rw-r--r--games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild b/games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild
new file mode 100644
index 000000000000..13d41d77c5c5
--- /dev/null
+++ b/games-arcade/grande-KXL/grande-KXL-0.6-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop
+
+DESCRIPTION="ZANAC type game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/gamestat
+ dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi
+ media-fonts/font-bitstream-100dpi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-highscore-path="${EPREFIX}/var/games"
+}
+
+src_install() {
+ dodir /var/games
+ default
+
+ fowners :gamestat /var/games/grande.scores /usr/bin/grande
+ fperms g+s /usr/bin/grande
+ fperms 660 /var/games/grande.scores
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry grande Grande
+}