summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/missile
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/missile')
-rw-r--r--games-arcade/missile/Manifest1
-rw-r--r--games-arcade/missile/files/missile-1.0.1-ldflags.patch15
-rw-r--r--games-arcade/missile/metadata.xml8
-rw-r--r--games-arcade/missile/missile-1.0.1.ebuild54
4 files changed, 78 insertions, 0 deletions
diff --git a/games-arcade/missile/Manifest b/games-arcade/missile/Manifest
new file mode 100644
index 000000000000..981e6028f224
--- /dev/null
+++ b/games-arcade/missile/Manifest
@@ -0,0 +1 @@
+DIST missile-1.0.1.tar.gz 214933 SHA256 fd6d4c42ebc48ab305c4fd027b1b793aa1a8c71c7b61c8fc4040dc21c1ff7d3b SHA512 32d30213d433fd3d02d74c4614747bdc2e3012c77793dfb7b869d774b7f43f4d0eb6b1a0e5db805d976e7919404c57cbbaa20f21954dfd4475ddaa6c2f6c0cc2 WHIRLPOOL 507c5c75de26543ecfa1be745794974c92d358e86aa75532f87c82b2ca50fc4bbf4130af913f61c1319f99d7ea1e38aeef08c914df5068c1247acc3300adffbe
diff --git a/games-arcade/missile/files/missile-1.0.1-ldflags.patch b/games-arcade/missile/files/missile-1.0.1-ldflags.patch
new file mode 100644
index 000000000000..5d2288165745
--- /dev/null
+++ b/games-arcade/missile/files/missile-1.0.1-ldflags.patch
@@ -0,0 +1,15 @@
+--- Makefile.old 2010-09-22 09:11:48.000000000 +0200
++++ Makefile 2010-09-22 09:13:08.000000000 +0200
+@@ -125,10 +125,10 @@
+ fi
+
+ $(PROGRAM): $(OBJECTS)
+- $(CC) -o $(PROGRAM) $(OBJECTS) $(CFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(PROGRAM) $(OBJECTS) $(CFLAGS) $(LIBS)
+
+ static : $(OBJECTS)
+- $(CC) -o $(PROGRAM) $(OBJECTS) $(CFLAGS) $(STATIC_LIBS)
++ $(CC) $(LDFLAGS) -o $(PROGRAM) $(OBJECTS) $(CFLAGS) $(STATIC_LIBS)
+
+
+ %.o : %.c %.h
diff --git a/games-arcade/missile/metadata.xml b/games-arcade/missile/metadata.xml
new file mode 100644
index 000000000000..1a96d428e816
--- /dev/null
+++ b/games-arcade/missile/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">missile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/missile/missile-1.0.1.ebuild b/games-arcade/missile/missile-1.0.1.ebuild
new file mode 100644
index 000000000000..0ea082c7011b
--- /dev/null
+++ b/games-arcade/missile/missile-1.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="The game Missile Command for Linux"
+HOMEPAGE="http://missile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc ~sparc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e "s:\$(game_prefix)/\$(game_data):${GAMES_DATADIR}/${PN}:" \
+ -e "s/-O2/${CFLAGS}/" \
+ -e 's/-lSDL_image $(SND_LIBS)/-lSDL_image -lm $(SND_LIBS)/g' \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ newicon -s 48 icons/${PN}_icon_black.png ${PN}.png
+ make_desktop_entry ${PN} "Missile Command"
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}