summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-30 01:54:50 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-30 21:38:28 +0100
commit87bdf8afe75a1eac7a4182d7d645741b50ffe93f (patch)
treeeb81af325c8f9e0e4a4be84e48bb81299c0acbb2 /games-arcade/supertux
parentdev-tcltk/tkzinc: fix build of doc (diff)
downloadgentoo-87bdf8afe75a1eac7a4182d7d645741b50ffe93f.tar.gz
gentoo-87bdf8afe75a1eac7a4182d7d645741b50ffe93f.tar.bz2
gentoo-87bdf8afe75a1eac7a4182d7d645741b50ffe93f.zip
games-arcade/supertux: Bump to version 0.6.3
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-arcade/supertux')
-rw-r--r--games-arcade/supertux/Manifest1
-rw-r--r--games-arcade/supertux/supertux-0.6.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/games-arcade/supertux/Manifest b/games-arcade/supertux/Manifest
index 9ffef0fc9534..4fe1b6e31bdb 100644
--- a/games-arcade/supertux/Manifest
+++ b/games-arcade/supertux/Manifest
@@ -1 +1,2 @@
DIST SuperTux-v0.6.2-Source.tar.gz 174295862 BLAKE2B 1179a5ecf92dfb2ac56b87afe4fed21a2bdc1d7f91641fea8aafc2994ccfe49745420411f41b2145f06fa9714c73d75ecbc85160e85edcbd71c472026cefe708 SHA512 5baa783ee589b42a9bbce3740659dbb7b617ebfcc00c0a038c03d31b56700e3923c8548700ccebe42b325ca03bd85186bc5edef9f6580d93dc48d8aca88cbf74
+DIST SuperTux-v0.6.3-Source.tar.gz 182065428 BLAKE2B c4acbe2c61306e6e462a375205b4e95af174c87dbc391f15211e1fac365ab51147d7a83d20a90e35f7d7a994c72b560631ddf1686fee2e1f937f97a711fb1003 SHA512 c6540bab1b3befbd975756031c4587e5569d9613d9539dc829c728b574d1a4da92816d6a7e68947b32963cc13d9b8b52312701c199138640e9f89e5885433798
diff --git a/games-arcade/supertux/supertux-0.6.3.ebuild b/games-arcade/supertux/supertux-0.6.3.ebuild
new file mode 100644
index 000000000000..93f09e6450c8
--- /dev/null
+++ b/games-arcade/supertux/supertux-0.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+#: ${CMAKE_MAKEFILE_GENERATOR:=emake}
+inherit cmake flag-o-matic
+
+MY_PV="${PV/_rc/-rc.}"
+MY_P="SuperTux-v${MY_PV}-Source"
+
+DESCRIPTION="A game similar to Super Mario Bros"
+HOMEPAGE="https://supertux.org/"
+SRC_URI="https://github.com/SuperTux/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+ GPL-3+ ZLIB MIT CC-BY-SA-2.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug"
+
+# =media-libs/libsdl2-2.0.14-r0 can cause supertux binary to move entire
+# content of ${HOME} to ${HOME}/.local/share/supertux2/
+# DO NOT REMOVE THIS BLOCKER!!! See bug #764959
+RDEPEND="
+ !=media-libs/libsdl2-2.0.14-r0
+ >=dev-games/physfs-3.0
+ dev-libs/boost:=[nls]
+ media-libs/freetype
+ media-libs/glew:=
+ media-libs/libpng:0=
+ >=media-libs/libsdl2-2.0.1[joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ >=media-libs/sdl2-image-2.0.0[png,jpeg]
+ >=net-misc/curl-7.21.7
+ virtual/opengl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0-tinygettext.patch
+ "${FILESDIR}"/${PN}-0.6.0-{license,icon,obstack}.patch
+)
+
+src_configure() {
+ append-cxxflags -std=c++11
+
+ local mycmakeargs=(
+ -DWERROR=OFF
+ -DINSTALL_SUBDIR_BIN=bin
+ -DINSTALL_SUBDIR_DOC=share/doc/${PF}
+ -DINSTALL_SUBDIR_SHARE=share/${PN}2
+ -DENABLE_SQDBG="$(usex debug)"
+ -DUSE_SYSTEM_PHYSFS=ON
+ -DIS_SUPERTUX_RELEASE=ON
+ )
+ cmake_src_configure
+}